Issues resolved in AppManager Agent 7.0.25142.0 Hotfix 72616 (NETIQKB72616)

  • 7772616
  • 07-Oct-2010
  • 06-Sep-2011

Environment

NetIQ AppManager 6.x
NetIQ AppManager 7.0.x

Situation

AppManager Agent 7.0.25142.0 Hotfix 72616 - agent fails to access the local repository and then stops forwarding information. Restarting the Windows agent service restores functionality but does not prevent the issue from occurring again.

Resolution

Hotfix 72616 for the AppManager version 6.0.2 and 7.0.x has been released to correct these issues.  To correct these issues, you will need to download and install Hotfix 72616 as indicated in this article or in the Readme file that is included with the Hotfix package from the following location:

AM7025_HF72616

Why Install This Hotfix?

This hotfix resolves the following Windows agent issues:

  • Resolves an issue where the Windows agent fails to access the local repository and then stops forwarding information. Restarting the Windows agent service restores functionality but does not prevent the issue from occurring again. (ENG270055).
  • Resolves an issue where jobs persist in a running inactive state when you reboot the computer while the Windows agent is not in maintenance mode. (ENG270992)
  • Resolves an issue where the Action_SMTPMail Knowledge Script can return maximum string length errors and can truncate incoming data. (ENG279258)
  • Resolves an issue where the Windows agent cannot process incoming events or data when the detailed message contains more than 20,479 characters. When the local repository receives an event or datum exceeding this limit, the Windows agent cannot process it and cannot process any other events or data in the local repository and outputs the following messages to the ccmtrace log: (ENG279882)
    For data:

SQLSTATE=01004, NativeErr=5, msg=<[Microsoft][ODBC Microsoft Access Driver]String data, right truncated on column number 8 (AgentMsg)>

>
1258108070 [29972] cmdb-load: oper abort, err=<[CMData]: repository error SQLSTATE=01004, NativeErr=5, msg=<[Microsoft][ODBC Microsoft Access Driver]String data, right truncated on column number 8 (AgentMsg)>
>

For events:

1257985605 [2232] rpevent-batchload: err <[CMEvent]: repository error SQLSTATE=01004, NativeErr=5, msg=<[Microsoft][ODBC Microsoft Access Driver]String data, right truncated on column number 22 (AgentMsg)>

>
1257985605 [2232] cmdb-load: oper abort, err=<[CMEvent]: repository error SQLSTATE=01004, NativeErr=5, msg=<[Microsoft][ODBC Microsoft Access Driver]String data, right truncated on column number 22 (AgentMsg)>
>

  • Resolves an issue where the Windows agent NetIQmc service crashes when you add write or edit permission for the cryptkey to an administrator group that already has it. To avoid the issue, check the existing cryptkey permissions for an administrator group before attempting to add new ones. (ENG281827)
  • Resolves an issue where the NetIQ diagnostic utility terminates unexpectedly after you click Diagnose. (ENG300101)
  • Resolves an issue where the SQL-RT ODBC query script generates events for a target server when the server is in maintenance mode. (ENG279739)

System Requirements

NetIQ Corporation recommends that you apply the following hotfixes before you apply this hotfix:

  • Hotfix 71949, for Control Center.
  • Hotfix 72041, for the management server.
  • Hotfix 72212, for the Operator Console.
  • Hotfix 71473, for the Operator Web Console.
  • Hotfix 72040, for the AppManager repository.

This hotfix supports AppManager agents on the following operating systems and platforms:

  • Windows Server 2003 Service Pack 2 Standard and Enterprise editions on 32-bit, 64-bit, and Itanium processors
  • Windows Server 2003 R2 Service Pack 2 Standard and Enterprise editions on 32-bit and 64-bit processors
  • Windows Server 2008 Service Pack 2 Enterprise edition on 32-bit and 64-bit processors
  • Windows Server 2008 R2 on 64-bit and Itanium processors
  • Windows Vista Service Pack 2 Enterprise edition on 32-bit and 64-bit processors
  • Windows 7 on 32-bit and 64-bit processors
  • Windows XP Service Pack 2 on 32-bit and 64-bit processors
  • Windows 2000 Standard Server Service Pack 4 on 32-bit processors
  • Windows 2000 Advanced Server Service Pack 4 on 32-bit processors

Contents of the Download Package

The download package has the following directory structure:

AM7025_HOTFIX72616
|  AM7025_ReadMe72616.htm
|
+---New Agent Install and 6x Agent Upgrade
|      NetIQ AppManager agent.msi
|      AM70-WinOS-7.6.276.0.xml
|      AM70-WinOS-7.6.276.0.msi
|      AM70-WinOS-7.6.276.0.ini
|      AM70-WindowsAgent-7.0.25142.0.xml
|
\---7.0.1 and 7.0.2 Agent Update
    |  AM7025_Hotfix72616_Setup.exe
    |  BaseInstall.dll
    |  MFC71u.dll
    |  msvcp71.dll
    |  msvcr71.dll
    |  Patch.ini
    |
    \---Setup Files
           AM70-WindowsAgentUpdate-7.0.25142.0.xml
           AM7025_Hotfix72616_MCSetup.msp
           AM70-WinOS-7.6.276.0.xml
           AM70-WinOS-7.6.276.0.msi
           AM70-WinOS-7.6.276.0.ini

The download package includes the files necessary for the following installation scenarios:

  • Install a new version 7.0.25142.0 agent.
  • Upgrade a version 6.0.2 or 6.0.3 agent to version 7.0.25142.0.
  • Update a version 7.0.1 or 7.0.2 agent to version 7.0.25142.0.

Cause

Known issue in the AppManager Agent.

Additional Information

Formerly known as NETIQKB72616

Files to Install a New Agent or Upgrade a 6.0.2 or 6.0.3 Agent

The download package contains the following files for installing a new version 7.0.25142.0 agent or upgrading a version 6.0.2 or 6.0.3 agent to version 7.0.25142.0:

  • AM7025_ReadMe72616.htm, this readme.
  • In the New Agent Install and 6x Agent Upgrade folder:

    • NetIQ AppManager agent.msi, the Windows agent installation program.
    • AM70-WindowsAgent-7.0.25142.0.xml, which you can use to install or upgrade more agents on remote Windows computers in your environment. For more information, see Installing This Hotfix Remotely.
    • AM70-WinOS-7.6.276.0.msi, the AppManager for Windows module installation program.
    • AM70-WinOS-7.6.276.0.xml, the remote AppManager for Windows module installation package. Use this package to install the AppManager for Windows module on remote Windows computers in your environment. For more information about remotely installing the module, see Installing This Hotfix Remotely.
    • AM70-WinOS-7.6.276.0.ini, the AppManager for Windows module installation program configuration settings.


Files to Update a 7.0.1 or 7.0.2 Agent

The download package contains the following files for updating a version 7.0.1 or 7.0.2 agent to version 7.0.25142.0:

  • AM7025_ReadMe72616.htm, this readme.
  • In the 7.0.1 and 7.0.2 Agent Update folder:

    • AM7025_Hotfix72616_Setup.exe, the hotfix setup program.
    • BaseInstall.dll
    • MFC71u.dll
    • msvcp71.dll
    • msvcr71.dll
    • Patch.ini
  • In the 7.0.1 and 7.0.2 Agent Update\Setup Files folder:
    • AM7025_Hotfix72616_MCSetup.msp, which the hotfix setup program automatically runs to update the Windows agent.
    • AM70-WindowsAgentUpdate-7.0.25142.0.xml, which you can use to update more agents on remote Windows computers in your environment. For more information, see Installing This Hotfix Remotely.
    • AM70-WinOS-7.6.276.0.msi, the AppManager for Windows module installation program.
    • AM70-WinOS-7.6.276.0.xml, the remote AppManager for Windows module installation package. Use this package to install the AppManager for Windows module on remote Windows computers in your environment. For more information about remotely installing the module, see Installing This Hotfix Remotely.
    • AM70-WinOS-7.6.276.0.ini, the AppManager for Windows module installation program configuration settings.


Installing This Hotfix

This hotfix supports the following installation scenarios:

  • Install a new version 7.0.25142.0 agent.
  • Upgrade a version 6.0.2 or 6.0.3 agent to version 7.0.25142.0.
  • Update a version 7.0.1 or 7.0.2 agent to version 7.0.25142.0.


Installing to Computers with User Access Control Enabled

If you are installing to a computer with User Access Control (UAC) enabled, you must run the installation program with administrative privileges.

To run the installation program with administrative privileges:

  1. From the Start menu, right-click Command Prompt and select Run as administrator.
  2. Select the administrator account and enter the password, then click OK.

Installing a New Agent or Upgrading a 6.0.2 or 6.0.3 Agent

Notes:
When you install a new agent or upgrade a 6.0.2 or 6.0.3 agent, you must also install the latest version of the AppManager for Windows module and check in the associated Knowledge Scripts in order to discover the agent.

If you do not install the AppManager for Windows module, you might encounter an "Invalid procedure call" error if you attempt to run the NT_DiskSpace or NT_LogicalDiskStats Knowledge Scripts. Knowledge Script jobs that report this error do not raise any alerts or generate events. Also, if you have any existing jobs running based on the NT_DiskSpace or NT_LogicalDiskStats Knowledge Scripts, you must propagate the new Knowledge Scripts to the existing jobs or create new jobs with the new Knowledge Scripts. Otherwise these existing jobs will produce the same "Invalid procedure call" error.

To install a new version 7.0.25142.0 agent or upgrade a version 6.0.2 or 6.0.3 agent to version 7.0.25142.0:

  1. If UAC is enabled on the computer, open a command prompt as administrator. For more information, see Installing to Computers with User Access Control Enabled.
  2. If UAC is not enabled on the computer, open a command prompt.
  3. On the command line, type the following command:

    msiexec /i "path to NetIQ AppManager agent.msi" /l*v "Windows_Installer_Log"

    Windows_Installer_Log is the path to the Windows installer log file. For example, "C:\Program Files\NetIQ\temp\NetIQ_Debug\AM7025_Hotfix72616_MCSetup.msp.log".
  4. To install the latest version of the AppManager for Windows module, run AM70-WinOS-7.6.276.0.msi on the computer where you installed or upgraded the agent, the AppManager repository computer, and the Control Center computer.

    Note:
    If you install the AppManager for Windows module to a computer with UAC enabled, you must run the installer as administrator. To do this, open a command prompt as administrator and run the installer from the command prompt. For more information, see Installing to Computers with User Access Control Enabled.
  5. To discover the agent, check in the Knowledge Scripts for version 7.6.276.0 of the AppManager for Windows module, then run the Discovery_NT Knowledge Script.

Updating a 7.0.1 or 7.0.2 Agent

If you are updating a 7.0.1 or 7.0.2 agent, use the files in the 7.0.1 and 7.0.2 Agent Update\Setup Files folder.

Notes:
If you install the update and the AppManager for Windows module to a computer with UAC enabled, you must run the installers as administrator. To do this, open a command prompt as administrator and run the installers from the command prompt. For more information, see Installing to Computers with User Access Control Enabled.

When you update a 7.0.1 or 7.0.2 agent, you must also install version 7.6.274.0 of the AppManager for Windows module. If you do not install the latest version of the AppManager for Windows module, you might encounter an "Invalid procedure call" error if you attempt to run the NT_DiskSpace or NT_LogicalDiskStats Knowledge Scripts. Knowledge Script jobs that report this error do not raise any alerts or generate events. Also, if you have any existing jobs running based on the NT_DiskSpace or NT_LogicalDiskStats Knowledge Scripts, you must propagate the new Knowledge Scripts to the existing jobs or create new jobs with the new Knowledge Scripts. Otherwise these existing jobs will produce the same "Invalid procedure call" error.

To update a version 7.0.1 or 7.0.2 agent to version 7.0.25:

  1. Run AM7025_Hotfix72616_Setup.exe on the computer with the version 7.0.1 or 7.0.2 agent you want to update.

    Note:
    Because other AppManager components that do not have a version 7.0.25 agent share the installation program, the title bar on the AppManager Update Install and Finish screens displays version 7.0.1.
  2. Install the latest version of the AppManager for Windows module by running AM70-WinOS-7.6.276.0.msi on the computer where you updated the agent.


The PATCH.log file lists all changes and problems encountered during the installation process. The Windows installer log file, AM7025_Hotfix72616_MCSetup.msp.log, lists only the changes associated with the hotfix installation. By default, these files are located in the \NetIQ\Temp\NetIQ_Debug folder.

Installing This Hotfix Remotely

If you have the following AppManager components installed, you can install or upgrade more agents on remote Windows computers in your environment:

  • AppManager repository (QDB)
  • Management server
  • Control Center console
  • Deployment services
  • Windows agent

To remotely install a new version 7.0.25 agent or upgrade a version 6.0.2, 6.0.3, 7.0.1, or 7.0.2 agent to version 7.0.25:

  1. On the Control Center console Administration pane, select Packages under the Deployment folder.
  2. On the Tasks pane, click Check in Packages.
  3. If you are installing a new version 7.0.25 agent or upgrading a version 6.0.2 or 6.0.3 agent, navigate to the New Agent Install and 6x Agent Upgrade folder and open AM70-WindowsAgent-7.0.25142.0.xml.

    The Deployment Package Check in Status dialog box displays the status of the package check in.
  4. If you are updating a version 7.0.1 or 7.0.2 agent, navigate to the 7.0.1 and 7.0.2 Agent Update folder and open AM70-WindowsAgentUpdate-7.0.25142.0.xml from the Setup Files subfolder.

    The Deployment Package Check in Status dialog box displays the status of the package check in.
  5. Configure a deployment rule to select the computers where you want to install or update the agent.
  6. Repeat the steps above to use AM70-WinOS-7.6.276.0.xml to remotely deploy the latest version of the AppManager for Windows module.


For more information about remote installation, see the Control Center User Guide on the AppManager Documentation web site.

For information on silent installations, please see the read me associated with the hotfix.