Zoned core services is not able to register an agent. (NETIQKB72560)

  • 7772560
  • 26-Aug-2010
  • 08-Sep-2010

Environment

NetIQ Secure Configuration Manager 5.8

NetIQ Secure Configuration Manager 5.8.1

NetIQ Secure Configuration Manager 5.7

Situation

Report hangs in pending in a multi-core environment.
Unable to communicate with Zoned Core server.
Error message when trying to register an endpoint in a multi-core environment.
Core Services in a zone is unable to communicate to other zoned cores and agents even with a host file in place.

Resolution

To resolve this issue an entry needs to be added to the mk.options file on every zoned core server to instruct core services to not bind to the local IP address.  Follow the instructions below to implement this change.

  1. Log onto the primary core server and stop the NetIQ Core Services service.
  2. Then go to %program files%NetIQ\Secure Configuration Manager\Core Services and locate the mk.options file.
  3. Select the mk.options file and make a copy of this file and place it in a safe directory. 
  4. Then select the file again and open it with a text editor. 
  5. Paste this line at the bottom of the file: server/socket/bind/local=false
  6. Perform the previous steps on the other zoned core services leaving the Core Services service stopped.
  7. Once this change has been made on all of the zoned Core Services start the Core Services service in order.  IE Primary, then zone 2 etc.

Cause

The local ip address on the Core Services machine is being bound to by the service.  This ip address is not the correct ip to route the communication between the zoned core servers.  Either the entry in the host file is incorrectly being used or the actual ip address is not able to be routed. 

Additional Information

Formerly known as NETIQKB72560