Error when logging in to the Aegis Web Console. Client text mapper is undefined. (NETIQKB72540)

  • 7772540
  • 18-Aug-2010
  • 02-Sep-2011

Environment

NetIQ Aegis 2.0
NetIQ Aegis 2.1
NetIQ Aegis 2.2
Microsoft URLScanner
Microsoft IIS 6.0
Microsoft Windows Server 2003

Situation

Error when logging in to the Aegis web console. Client text mapper is undefined.
The IIS log will present an error such as the one indicated below:

URLScan rejecting. 2010-08-18 20:38:10 W3SVC1 142.241.25.192 GET ~/Rejected-By-UrlScan~/Aegis/Resources/NetIQ.Aegis.Web.UI.Controls/scripts/ClientScriptCodeBehind.js 80

Resolution

In order to resolve this issue, follow the process below:

  1. Locate the file URLscan.ini on the client machine.  (Typically C:\Windows\System32\Inetsrv\URLScan)
  2. Edit the the file in notepad.
  3. Search for AllowDotInPath=0
  4. Modify AllowDotInPath=0 to AllowDotInPath=1
  5. Save the file.
  6. Log in to the NetIQ Aegis Web Console.

You should not be able to log in to the console with out error.

Cause

Microsoft URLScan has been installed on a server running IIS 6.0.

Additional Information

Formerly known as NETIQKB72540