Business Services will not start after a new install of Aegis 2.1 (NETIQKB72537)

  • 7772537
  • 17-Aug-2010
  • 02-Sep-2011

Environment

Microsoft Windows 2008
Microsoft Windows 7
NetIQ Aegis 2.1

Situation

Business Services will not start after a new install of Aegis 2.1.
Cannot connect to the Operations Console.
Business Services will not start after a new install of Aegis 2.1 on Microsoft Windows 2008 (x86) or Microsoft Windows 7.

Resolution

In order to correct this issue, please complete the following steps:

  1. Locate a copy of MSVCR71.DLL on a Windows 2003 or older server that has .Net 1.1 installed.
  2. Copy this file to the NetIQ\Aegis\Bussvr folder on your Business Server machine.
  3. Restart the Business Service Layer services
  4. Log in to the Operations Console.

The Operations Console should now allow you to login successfully.

Cause

NetIQ Aegis 2.1 requires that MSVCR71.dll be installed on the Business Service server.  The DLL is required as one of the libraries the Business Service Layer dynamically loads depends on it.  Microsoft Windows 2003 and earlier versions, the MSVCR7171.dll was available and typically shipped as part of .Net 1.1, however on Microsoft Windows 2008 and Microsoft Windows 7 .Net 1.1 is not shipped and thus the library is not available.

This issue has been corrected in NetIQ Aegis 2.2 and higher.

 

Additional Information

Formerly known as NETIQKB72537