NetIQ Aegis services will not start, fails after the NetIQ Aegis Service Account password is changed (NETIQKB72525)

  • 7772525
  • 12-Aug-2010
  • 02-Sep-2011

Environment

NetIQ Aegis 2.1
NetIQ Aegis 2.2

Situation

NetIQ Aegis services will not start, fails after the NetIQ Aegis Service Account password is changed
Changing the Service Account password for NetIQ Aegis results in some services not starting, or starting and then immediately stopping.
NetIQ Aegis Activity Broker Service starts and then immediately stops.
NetIQ Aegis Engine Service will not start.

Resolution

To correct this issue, you must save the new password in the following locations:

Services:-

All NetIQ Aegis Services running as this account must have the new password saved to them.  For each service, you should:

  1. Stop the affected service in the windows Services applet.
  2. Right-Click the service, select Properties.
  3. In the Service's properties window, select the Log On tab.
  4. Enter the new password in the appropriate fields.
  5. Click Apply, and OK.

Adapter Configuration Utility:-

You will need to store the new password in the NetIQ Aegis Adapter Configuration Utility, in the following locations:

  • Aegis Scheduler
    • Change the password stored here, for the Aegis Account.
  • Resource Management
    • Change the password stored here, for the Aegis Account.

You will also need to store a new password if this same Service Account is used for any NetIQ Aegis Adapters, which can be done at the Adapter level for each affected Adapter within the Adapter Configuration Utility.

Once these changes are made, you should be able to start all NetIQ Aegis Services normally.

Cause

The password must be reset (stored) in multiple locations, it is not enough to just change the stored password on the services themselves.

Additional Information

Formerly known as NETIQKB72525