Remote Deployment Tasks fail with error: 'The service is temporarily overloaded' (NETIQKB72469)

  • 7772469
  • 22-Jul-2010
  • 02-Aug-2010

Environment

NetIQ AppManager 7.0.x
NetIQ Control Center 7.0.x
NetIQ AppManager Control Center Deployment Web Service

Situation

Remote Deployment Tasks fail with error: 'The service is temporarily overloaded'
Deployemnt Service log, (ADSTrace.log) contains error: ComObjectError description: The service is temporarily overloaded
System Event log on the AppManager Control Center Deployment Web Server contains error 1059.

Resolution

The error is a result of BITS failing to initiate the file transfer of the desired deployment package to the target system or Agent because the AutoDeploymentAppPool service in IIS on the AppManager Control Center Deployment Web Server is disabled or failing.

Such conditions can be spotted in the System Event log as 1059 errors for the W3SVC service.

These errors can occur because the account that is set as the Identity of the ApplicationDeploymentAppPool is either an invalid domain account, or is an account with insufficient credentials to pose as the Identity for this IIS component.  It may also occur if the ApplicationDeploymentAppPool process is stopped.

The easiest thing to check and correct is to make sure that the ApplicationDeploymentAppPool process is running.  To do this, following these simple steps:

  1. Launch the Internet Information Services Manager tool on the Deployment Web Server server.
  2. In the left-hand tree view, locate and expand ApplicationPools
  3. In the IIS Manager tree view pane, right-click ApplicationDeploymentAppPool and select Start.

If the process starts and stops again, then the problem is most likely with the account that is set as the Identity of that process.  You have two things you can try at this point.

Option 1

Try setting the account that is currently configured as the Identity for teh ApplicationDeploymentAppPool service as a Local Admin on the server.  To do this, follow these steps:

  1. Launch the Internet Information Services Manager tool on the Deployment Web Server server.
  2. In the left-hand tree view, locate and expand ApplicationPools
  3. In the tree, below ApplicationPools, locate ApplicationDeploymentAppPool and right-click that, selecting Properties.
  4. In the Properties window, select the Identity tab.
  5. Note the username that is currently set as the Identity for this service, and then minimize the IIS Management window.
  6. Right-click My Computer, select Manage.
  7. In the Tree View pane, go to Computer Management (Local) | System Tools | Local Users and Groups and click on Groups.
  8. In the Groups list pane, right-click on Administrators and click Add to Group...
  9. In the Administrators Properties window, click on Add...
  10. Enter the name (domain\user) for the account currently listed as the Identity for the ApplicationDeploymentAppPool service.
  11. Click on Check Names to validate that the account info was correctly entered, and then click on OK.
  12. In the Administrators Properties window, click on Apply and OK.
  13. Close the Computer Management window.
  14. Restore the IIS Management window from the Task Bar.
  15. In the left-hand tree view, locate and expand ApplicationPools
  16. In the tree, below ApplicationPools, locate ApplicationDeploymentAppPool and right-click that, selecting Start.

If the service starts and continues to run normally, this issue is resolved.  If these steps do not resolve this issue, proceed to Option 2.

Option 2

Typically, if you switch the Identity for the ApplicationDeploymentAppPool in IIS back to the default "Network Service" account, and then re-enable the ApplicationDeploymentAppPool in IIS, this will correct the problem.  To do this, follow these steps:

  1. Launch the Internet Information Services Manager tool on the Deployment Web Server server.
  2. In the left-hand tree view, locate and expand ApplicationPools
  3. In the tree, below ApplicationPools, locate ApplicationDeploymentAppPool and right-click that, selecting Properties.
  4. In the Properties window, select the Identity tab.
  5. In the Identity tab, select the Network Service radio button.
  6. Click Apply and OK.
  7. In the IIS Manager tree view pane, right-click ApplicationDeploymentAppPool and select Start.

At this point it should be possible to re-enable a Deployment Task that previously failed with the error mentioned in the title of this article, and this task should complete successfully.

If none of these steps help to correct the errors mentioned in this article, please contact NetIQ Technical Support.

Cause

The "Identity" that the ApplicationDeploymentAppPool is running as in IIS is not a valid domain account, or does not have the appropriate permissions.

Additional Information

Formerly known as NETIQKB72469