Unable to login to AppManager Performance Profiler after applying Hotfix 1 for AMPP 4.1.2 SP2 (NETIQKB72456)

  • 7772456
  • 15-Jul-2010
  • 28-Feb-2012

Environment

NetIQ AppManager Performance Profiler v4.1.2 sp2

Situation

Unable to login to AppManager Performance Profiler after applying Hotfix 1 for AMPP 4.1.2 SP2
When logging into the user interface after applying hotfix 1 for sp2 the interface will indicate the following errors:

- HTTP Status 404
- The requested resource (/ampp/) is not available

AMPP interface login screen will not load after applying Hotfix 1 for AMPP 4.1.2 SP2

Resolution

The sql stored procedure contained in the sp2 hotfix 1 zip file update.sql needs to be run after the hotfix has been installed via the packages section of the console.

This stored procedure updates rows within the amppdb to reflect the new authentication method introduced.

From the Hotfix Readme:

Post Installation:
==================

To complete installation of this hotfix, a database script must be executed against your database.  To find the script, look into your AppManager Performance Profiler install directory and find the script <INSTALL_DIR>\db\src\mssql\update\update.sql.

1.  Execute the script against the AMPP database. You must use an account with rights to perform data updates.  No schema updates will be performed.
2.  Restart all AppManager Performance Profiler services.  They should have been stopped during the installation process.
3.  In the UI, navigate to Administration > Configuration > External Authentication.
4.  Select Native Authentication.  Set Enabled to "Yes" and Database Authorization to "No".  Setting Database Authorization to "Yes" would tell AMPP that you wish to handle user authorization directly using information in our database, rather than using information available from Active Directory.
5.  Restart Tomcat.

Cause

This issue is due to a change in the database properties.

Additional Information

Formerly known as NETIQKB72456