Report Server showing Red 'X' in Analysis Center 2.7.5 Console (NETIQKB72404)

  • 7772404
  • 17-Jun-2010
  • 17-Jun-2010

Environment

Analysis Center 2.7.5
Microsoft SQL Server Reporting Service 2008

Situation

Report Server showing Red 'X' in Analysis Center 2.7.5 Console


Analysis Center Console shows the Report Server as being down or unavailable.

Resolution

Since the Analysis Center console is defined so that it identifies the Report Server Service name using the report server URL, it requires the URL to be in a format like:

http://<WORKSTATION>/ReportServer$Instance

You will need to manually reconfigure the Report Server Virtual Directory on the SQL Server, using a '$' in place of the existing '_'.  You can accomplish this by completing the following steps:

  1. Click on Start.
  2. Select Microsoft SQL Server 2008 | Configuration Tools | Reporting Services Configuration Manager
  3. Verify that the entries for Server Name and Report Server Instance are correct and then click on Connect.
  4. Under Report Manager URL enter the correct Virtual Directory replacing the ?_? with a ?$?.
  5. Click on Apply.

Once this is done, re-add the new Report Server's URL in the Analysis Center Console under:

Tools | Options | Enterprise Options | Reporting Services | Default Report Server Location

The Report Server should show as green after this.

Cause

The Reporting Server Service Name is expected to always be in the following format:

ReportServer$Instance

Thus Analysis Center expects the Report Server URL to be in the following format:

http://<WORKSTATION>/ReportServer$Instance

When installing Microsoft SQL Server Reporting Service 2008, if you allow the installer to 'Auto Configure' the Report Server, the Report Server virtual directory will be created correctly.

However, if you uncheck the 'Auto Configure' option during installation and manually configure the report server virtual directory, it does not allow the '$'.  As a result it is instead configured with an '_'.

The false status is a result of the Report Server URL not being in the expected format.

Additional Information

Formerly known as NETIQKB72404

If you need further assistance with the subject matter discussed in this Knowledge Base Article, please contact NetIQ Technical Support.