Workitems lose their mappings to process revisions (NETIQKB72402)

  • 7772402
  • 16-Jun-2010
  • 02-Sep-2011

Environment

NetIQ Aegis 2.1

Situation

Workitems lose their mappings to process revisions

Resolution

Why Install This Hotfix?

This hotfix addresses the following issues:

Resolves an Issue where a Trigger Incorrectly Appends Matching Events After the Work Item is Completed - Before you apply this hotfix, triggers might continue to append matching events to a work item after the work item completes. After you apply this hotfix, triggers will correctly initiate new work items when matching events arrive after a work item completes. (ENG296464)

Resolves an Issue where the Manual Trigger Initiates Multiple Work Items From a Process - Before you apply this hotfix, the first time you use a manual trigger after putting a process in production, the manual trigger incorrectly initiates multiple work items. After you apply this hotfix, the manual trigger initiates the correct number of work items. (ENG296972)


Installing This Hotfix

Complete the following steps to install this hotfix.

To install this hotfix:

Log on to the Aegis Server computer with a local administrator account.
Run the Aegis21_Hotfix72402.exe file.
Follow the instructions in the wizard until you have finished installing the hotfix.
The hotfix installation program automatically restarts the following Aegis services:

NetIQ Aegis Namespace Provider
NetIQ Aegis Engine
NetIQ Aegis Activity Broker


Modified Files

This hotfix modifies the following files in the C:\Program Files\NetIQ\Aegis folder on the Aegis Server computer:

\IQConnect\bin\pg.dll (Build Number 1.4.2.128)
\IQConnect\bin\pg.map
\IQConnect\bin\pg.pdb
\IQConnect\bin\pgwfb.dll (version 2.1.2.128)
\IQConnect\bin\pgwfb.map
\IQConnect\bin\pgwfb.pdb
\IQConnect\bin\ProcessGovernanceEngine.exe (version 2.1.3.128)
\IQConnect\bin\ProcessGovernanceEngine.map
\IQConnect\bin\ProcessGovernanceEngine.pdb
\IQConnect\bin\wfe.dll (Build Number 2.1.2.128)
\IQConnect\bin\wfe.map
\IQConnect\bin\wfe.pdb
\IQConnect\mof\PG_1_3.mof
\DB\PGE\StoredProcedures\workflow.sql
\DB\PGE\StoredProcedures\workitem.sql

This hotfix adds the following files to the C:\Program Files\NetIQ\Aegis\IQConnect\HotFixes\Aegis21_Hotfix72402 folder on each computer where you install the hotfix:

Aegis21_Hotfix72402.log
Aegis21_Readme72402.htm
Install.log


Previous Releases

This hotfix also includes enhancements added in Hotfix 72240.

Resolves an Issue where Workflows Fail to Start - Before you apply this hotfix, workflows might occasionally fail to start. After you apply this hotfix, workflows will start correctly. (ENG274107)

Resolves an Issue where the Aegis Operations Console Times Out - Before you apply this hotfix, the Aegis Operations Console times out when you attempt to view all work items for a process. After you apply this hotfix, the Aegis Operations Console will correctly display all work items for a process. (ENG272582)

Resolves an Issue with the NetIQ Aegis Correlation Engine Service - Before you apply this hotfix, the NetIQ Aegis Correlation Engine service appears to be started but Aegis does not trigger work items. After you apply this hotfix, the NetIQ Aegis Correlation Engine service will correctly trigger work items. (ENG275603, ENG276325)

Resolves an Issue with the Capture New Report Data Job - Before you apply this hotfix, the Capture New Report Data job fails when converting data to an integer. After you apply this hotfix, the Capture New Report Data job will correctly convert data to an integer. (ENG267954)

Resolves an Issue with Tables in User Input Forms - Before you apply this hotfix, tables in user input forms display the error message, There are no rows to show in this view. After you apply this hotfix, tables in user input forms will function correctly. (ENG276519)

Resolves an Issue where Global Error Handling Causes a Work Item to Terminate Unexpectedly - Global error handling is not specific to a particular activity in the workflow. Before you apply this hotfix, if global error handling returns to the original activity that failed, the work item terminates immediately. After you apply this hotfix, if global error handling returns to the original activity that failed, the work item will terminate only if the activity fails a second time. Terminating after two failures prevents the workflow from becoming stuck in an infinite loop. (ENG278784)

Resolves an Issue where Workflows Fail to Initiate Work Items from Other Process - Before you apply this hotfix, workflows occasionally fail to initiate work items from other processes. After you apply this hotfix, workflows will correctly initiate work items from other processes. (ENG287567)

Cause

This hotfix for the NetIQ Aegis product (Aegis) resolves specific previous issues.

Additional Information

Formerly known as NETIQKB72402