Environment
Situation
Description of Incident Reports are displayed incorrectly after the upgrade to VPC 5.6.
When submitting an Incident Report as an Anonymous User, the Anonymous User is identified in the Audit Log.
"An error has been encountered" received when uploading a new Policy to VPC.
Enhancements to User phone fields to permit more (as well as special) characters.
Resolution
This hotfix resolves an issue where VigilEnt Policy Center displayed an error when customers tried to upload new policy documents. This issue occurred in VigilEnt Policy Center environments where customers had installed Java 6 Update 20. After you apply this hotfix, VigilEnt Policy Center allows you to upload policy documents without errors. (ENG290115)
This hotfix also includes the following fixes contained in VigilEnt Policy Center 5.6 hotfix 72258:
This hotfix resolves an issue with Incident Reporting. Before you apply this hotfix, when an anonymous user submits an Incident Report, VigilEnt Policy Center identifies that user by name and IP address in the audit log and event log. After you apply this hotfix, the audit log and event log do not provide any identifiable information for an anonymous user who submits an Incident Report. (ENG286680)
This hotfix also resolves an upgrade issue. Before you apply this hotfix, when you upgrade your environment to VigilEnt Policy Center 5.6, the product displays descriptions of old Incident Reports submitted before the upgrade as if they were encrypted, though new Incident Reports are correctly displayed. After you apply this hotfix, VigilEnt Policy Center displays all Incident Reports correctly. (ENG287811)
This hotfix provides enhancements to the Phone Number and Fax fields on the Incident Reporting window. After you apply this hotfix, you can enter a greater number of characters in these fields than previously allowed. In addition to standard numbers (such as 1, 2, or 3), you can use special characters such as the following: period (.), parentheses, space, forward slash (/), plus sign (+), letters, hyphen (-), asterisk (*), pound sign (#), or tilde (~). If you have any other international symbols available on your phone, you can enter them in these fields also. (ENG276468)
Note: This hotfix requires VigilEnt Policy Center 5.6.
Complete the following steps to install this hotfix.
To install this hotfix:
- Log on to the VigilEnt Policy Center server computer with a local administrator account.
- Run the VPC5600_Hotfix72390.exe file.
- Follow the instructions in the wizard until you have finished installing the hotfix.
This hotfix modifies the following files in the installation folder, by default C:\Program Files\NetIQ\VigilEnt Policy Center\:
- \server\shared\lib\vpc-gui.jar
- \server\shared\lib\vpc-news-gui.jar
- \server\shared\lib\vpc-policydocument-gui.jar
- \server\shared\lib\vpc-quiz-gui.jar
- \server\shared\lib\vpc-incident.jar
- \server\shared\lib\vpc-incident-gui.jar
- \server\shared\lib\vpc-install.jar
This hotfix also adds the following file in the installation folder: \database\update56toHF72390.txt. This file changes the product version stored in the database. Once you have installed the hotfix, you can verify the product version in the Administration Site. Click the Administration tab, and then click About. The Current Version should be 5.6 (72390).
Cause
Java 6 Update 20 introduced a problem in VPC that required a code change to correct the functionality of uploading policies.
VPC was capturing and placing in the Audit Log and Event Log the name and IP of the user submitting the incidents.
Existing Incident Reports are being displayed as if they were encrypted after the upgrade to VPC 5.6