Aegis cannot collect data from Security Manager using the Aegis Adapter for Security Manager (NETIQKB72383)

  • 7772383
  • 07-Jun-2010
  • 08-Jun-2010

Environment

NetIQ Aegis 2.x
NetIQ Aegis Adapter for Security Manager 1.2

Situation

Aegis cannot collect data from Security Manager using the Aegis Adapter for Security Manager
If you try to install the Aegis Adapter for Security Manager, version 1.2, the setup program cannot install the adapter completely and displays a warning that the installation was cancelled and could not be completed.

If the customer ignores the installation failure warning and tries to use the Security Manager adapter with Aegis, Aegis cannot collect Security Manager data and returns an error: "Activity failed. Error: IQConnect configuration missing."

Resolution

Before installing the Aegis Adapter for Security Manager, install the Microsoft Visual C++ 2005 Service Pack 1 Redistributable Package ATL Security Update, which can be downloaded from the following location:

http://www.microsoft.com/downloads/details.aspx?familyid=766a6af7-ec73-40ff-b072-9112bab119c2&displaylang=en

Follow the instructions provided on the Microsoft Website to install the ATL Security Update on the Aegis server in your environment.

If you install the adapter without first installing the more recent version of the Visual C++ runtime on the Aegis server, you can resolve the error above by installing the ATL Security Update.

Cause

Version 1.2 of the Aegis Adapter for Security Manager uses the Microsoft Visual C++ 2005 Service Pack 1 Redistributable Package ATL Security Update, while Aegis uses an earlier version of the Visual C++ runtime. Because the adapter and Aegis do not use the same runtime, the activity broker service cannot talk to the Security Manager adapter in the namespace service.

Additional Information

Formerly known as NETIQKB72383

If you need further assistance with the subject matter discussed in this Knowledge Base Article, please contact NetIQ Technical Support.