NetIQ Aegis incorrectly treats single character strings and empty strings as equal (NETIQKB72340)

  • 7772340
  • 24-May-2010
  • 02-Sep-2011

Environment

NetIQ Aegis 2.1

Situation

Issue with comparing single character strings to empty strings in NetIQ Aegis

Resolution

To correct this issue, please apply Hotfix 72340, which you can download here .

Why Install This Hotfix

Aegis incorrectly treats two dissimilar values as equal.  This hotfix resolves an issue with comparing single character strings to empty strings. Before you apply this hotfix, when Aegis compares a single-character string, such as A, to an empty string, Aegis incorrectly treats the two values as equal. After you apply this hotfix, Aegis will correctly recognize the different values when comparing a single-character string to an empty string. (ENG286868)

This Hotfix supercedes Hotfix 72232.


Installing This Hotfix

Complete the following steps to install this hotfix:

  1. Log on to the Aegis Server computer with a local administrator account.
  2. Run the Aegis21_Hotfix72340.exe file.
  3. Follow the instructions in the wizard until you have finished installing the hotfix.

If your Aegis environment has a separate Web Server computer, complete the following steps:

  1. Log on to the Web Server computer with a local administrator account.
  2. Run the Aegis21_Hotfix72340.exe file.
  3. Follow the instructions in the wizard until you have finished installing the hotfix.

The hotfix installation program automatically restarts the following Aegis services:

  • NetIQ Aegis Namespace Provider
  • NetIQ Aegis Engine
  • NetIQ Aegis Activity Broker
  • NetIQ Aegis Business Services


Modified Files

This hotfix modifies the following files in the C:\Program Files\NetIQ\Aegis\IQConnect\bin folder on the Aegis Server computer:

  • ns.dll (Build Number 7.2.58)
  • ns.pdb
  • ns.map

This hotfix modifies the ns.dll (Build Number 7.2.58) file in the C:\Program Files\NetIQ\Aegis\BusSrv folder on the Web Server computer.

This hotfix adds the following files to the C:\Program Files\NetIQ\Aegis\HotFixes\Aegis21_Hotfix72340 folder on each computer where you install the hotfix:

  • Aegis21_Hotfix72340.log
  • Aegis21_Readme72340.htm
  • Install.log

Cause

This issue is caused by a logic error in the Aegis Web component.

Additional Information

Formerly known as NETIQKB72340