NetIQ AppManager Client Communication Manager service will not start after a new Agent installation. (NETIQKB72326)

  • 7772326
  • 19-May-2010
  • 19-May-2010

Environment

NetIQ AppManager 7.x

Situation

NetIQ AppManager Client Communication Manager service will not start after a new Agent install.
Client Communication Manager service fails to start with error: 'The service cannot be started either because it is disabled or because it has no enabled devices associated with it.'

When starting the NetIQ Client Communication manager in console mode, an error is displayed indicating that the service failed to connect to the local repository.

Resolution

Two things to verify, in order to correct this issue:

  1. The account being used to install the Agent must have explicit 'Local Administrator' rights on the agent machine.  i.e. It must be added to the Local Administrators group on the target system.
  2. Make sure that during the installation of the Agent, the account that you set to be the "Log on as" account for the two Agent services has 'Local Administrator' rights on the target system.  i.e. The Account that will be used to run the two AM Agent Services must be explicitly added to the Local Administrators Group on the target system.
    If you need further assistance with this issue, please contact NetIQ Technical Support.

If you need further assistance with this issue, please contact NetIQ Technical Support.

Cause

The account being used to install the agent either does not have permissions to do so on the local machine, or that account does not have permissions to make changes to the Local Repository once it has been created.

Additional Information

Formerly known as NETIQKB72326