NetIQ Analysis Center AC_OLAP Analysis Services database is taking up large amounts of disk space. (NETIQKB72250)

  • 7772250
  • 22-Apr-2010
  • 08-Dec-2010

Environment

NetIQ Analysis Center 2.7
NetIQ Analysis Center 2.7.5
Microsoft SQL Server 2005
Microsoft Analysis Services 2005

Situation

NetIQ Analysis Center AC_OLAP Analysis Services database is taking up large amounts of disk space.
Dropped or orphaned data files exist in the Analysis Services OLAP directories.

Resolution

The following steps will reclaim some disk space:
  1. Disable & stop the ETL & OLAP jobs from running at this time.
  2. Verify anti-virus on-access scanning configurations & exclude any SQL or Analysis Services installation & data directories.
  3. Manually start the Analysis Center Installation SQL job.  This will actually drop & rebuild the Analysis Services AC_OLAP database.  The process will recreate the Analysis Center OLAP processing job & re-enable the job.  This may take several hours for the OLAP processing job to complete, but should remove all orphaned files & compact the AC_OLAP DB.
  4. If the above steps are successful, start & allow to complete the ETL jobs one at a time if there are multiples.
  5. If all the steps above complete successfully, review your data mart databases for any white space & shrink the database files if required to re-claim disk space.

If any of the above steps fail, please halt all actions and contact NetIQ Technical Support with the specific error or problem you are experiencing.

Cause

This issue can occur if you have not excluded the SQL & Analysis Services data directories from any "On-Access" virus scanning per Microsoft recommendations.  This in turn may result in some dropped or orphaned files being left in the Analysis Services OLAP database directory.

Additional Information

Formerly known as NETIQKB72250