Error: NetIQmc: [7344] Fail to initialize VB engine, abort! (NETIQKB72243)

  • 7772243
  • 21-Apr-2010
  • 21-Apr-2010

Environment

AppManager 7.x

Situation

The NetIQ AppManager Agent does not start and the following message is logged in the Application Event Log:

Error: NetIQmc: [7344] Fail to initialize VB engine, abort!
After installation of the agent discovery scripts are stuck pending (start).
Unable to connect to netiqmc service via RPC on port 9998.

Resolution

Kaspersky has released a critical fix 7 that updates its software to 6.0.2.566 from .555 and specifically identifies this incompatibility with the NetIQ AppManager product. Additional, information on this issue is available by clicking on the link below:

http://www.kaspersky.com/technews?id=203038751

To resolve this issue update Kaspersky to version 6.0.2.566 or later.

Cause

Kaspersky 6.0 Enterprise Anti-Virus version 6.0.2.555 has a script interceptor service that appears to interfere with NetIQmc when it attempts to initialize the VBScript engine. It creates the following error event in the application event log:

[7344] Fail to initialize VB engine, abort!

And also the following error message in the mctrace.log or when run from the console:

[9428] vbengine-vinit: creating VBS engine instance
[9428] vbengine-vinit: operation fail, err=8007000e
[9428] ImpVbeng-init failed to initialize VbEngine instance
[9428] entity-eReferenced: <vbengine> refcnt 0
[9428] Fail to initialize VB engine, abort!

Additional Information

Formerly known as NETIQKB72243