Timeout occurs when logging into Aegis Consoles (NETIQKB72189)

  • 7772189
  • 05-Apr-2010
  • 02-Sep-2011

Environment

NetIQ Aegis 2.1

Situation

Timeout occurs when logging into the Aegis Consoles
The Aegis script NetIQ Purge Resources from Data Sources IQRM takes longer than 10 minutes to process

The Aegis script NetIQ Purge Resources from Data Sources process prevents workflows from running until the script completes

The Aegis Operations Console and the Aegis Configuration Console time out when a user attempts to log on

Some NetIQ Aegis Adapters cannot synchronize duplicate resource names to the Resource Management database

Resolution

These issues are corrected by Hotfix 72189 for NetIQ Aegis 2.1.  You can access a copy of the Hotfix here.

Why Install This Hotfix?

This hotfix addresses the following issues:

Resolves an Issue with an Aegis Script - This hotfix resolves an issue where the Aegis script NetIQ Purge Resources from Data Sources IQRM takes longer than 10 minutes to process and prevents workflows from running until the script completes. In general, the delay occurs when the Aegis database contains data for more than 1,000 computers. (ENG274294)

Resolves an Issue with the Aegis Consoles Timing Out at Logon - This hotfix resolves an issue where the Aegis Operations Console and the Aegis Configuration Console time out when a user attempts to log on. (ENG285156)

Resolves an Issue with Synchronizing Resource Groups - Before you apply this hotfix, if a resource group at the top level of the namespace hierarchy for an adapter has the same name as a resource group lower in the hierarchy, the adapter cannot synchronize the duplicate names to the Resource Management database. After you apply this hotfix, the adapter will be able to correctly synchronize duplicate resource group names to the Resource Management database. (ENG287666)


Installing This Hotfix

Complete the following steps to install this hotfix:

  1. Log on to the Aegis Server computer with a local administrator account.
  2. Run the Aegis21_Hotfix72189.exe file.
  3. Follow the instructions in the wizard until you have finished installing the hotfix.

The hotfix installation program automatically restarts the following Aegis services:

  • NetIQ Aegis Namespace Provider
  • NetIQ Aegis Engine
  • NetIQ Aegis Activity Broker

Modified Files

This hotfix modifies the following files in the C:\Program Files\NetIQ\Aegis\iqrmdb\IQRM\StoredProcedures folder on the Aegis Server computer:

  • Path.sql
  • Computer.sql
  • ResourceGroup.sql

This hotfix adds the following files to the C:\Program Files\NetIQ\Aegis\IQConnect\HotFixes\Aegis21_Hotfix72189 folder on the Aegis Server computer:

  • Aegis21_Hotfix72189.log
  • Aegis21_Readme72189.htm
  • Install.log

This hotfix adds the Upgrade_1_1_2_0_to_1_1_2_1.sql file to the C:\Program Files\NetIQ\Aegis\iqrmdb\IQRM folder on the Aegis Server computer.

Previous Releases

This hotfix also includes enhancements added in Hotfix 71807.

Resolves an Issue with an Aegis Script - This hotfix resolves an issue where the Aegis script NetIQ Purge Resources from Data Sources IQRM takes longer than 10 minutes to process and prevents workflows from running until the script completes. (ENG274294)

Cause

These issues are caused by known problems in the NetIQ Aegis Core Components, and resolved by applying the hotfix below.

 

Additional Information

Formerly known as NETIQKB72189