Log Archive service will not start (NETIQKB72186)

  • 7772186
  • 01-Apr-2010
  • 05-Apr-2010

Environment

NetIQ Security Manager 6.x Log Archive server

 

Situation

When trying to start the Log Archive Service, it errors out after a few seconds with error 1064: an exception occurred in the service when handling the control request.

Event id 1020

Event id 1030

Event id 1032

Logarchiveserver.txt: F:\NetIQSMLogArchive\20100329\PartitionInfo.xml 2010-03-30 04:21:15,897 [27] ERROR NetIQ.Threading.Scheduler: ScheduledJob.Run: unhandled exception in scheduled work item System.InvalidOperationException: There is an error in XML document (0, 0). ---> System.Xml.XmlException: Root element is missing.

Resolution

To find the empty or corrupt partitioninfo.xml, see the following steps:

  1. Open Documents and settings\all users\application data\netiq\security manager\log files\logarchiveserver.txt

  2. Search for keywords from the following string:

    There is an error in XML document (0, 0). ---> System.Xml.XmlException: Root element is missing.

  3. Once the partition that contains the empty or corrupt partitioninfo.xml file is found, rename the partition. E.g. 20100327 to 20100327old
    • If the impacted partition does not contain any .NDS files, it can simply be deleted.
    • If the the impacted partition does contain .NDS files, it needs to be reindexed.

  4. Start the Log Archive Service.

 

Cause

One or more of partioninfo.xml files is empty or corrupt

Additional Information

Formerly known as NETIQKB72186

  • To reindex the partition, refer to the Log Archive Resource Kit PDF or NETIQKB72176.

  • To recreated the corrupted partitioinfo.xml see NETIQKB72176.

  • Make sure to backup the entire partition before starting the reindexing process.