Scheduled a report to distribute a file for a report and no file is written to the target directory. (NETIQKB72159)

  • 7772159
  • 23-Mar-2010
  • 06-Apr-2012

Environment

NetIQ Secure Configuration Manager 5.8

Situation

Scheduled a report to distribute a file for a report and no file is written to the target directory.
Target directory is emptly when report distribution is setup to post the file to a share or directory.

Resolution

  • Failed reports are not distributed and the failure must be resolved and the report run again to be distributed. The original failed report can not be distributed after the failed run, only a report that is succesful can be distributed. 
  • If the report was succesful and it did not write to the directory then the permissions were the cause of the issue.  Start the NetIQ Core Services service with an account that has authority to remotely connect and write to the target directory.
  1. On the machine where Core Services is installed go to start\run and type services.msc
  2. When the services window appears select the NetIQ Core Services service and right click and select properties.
  3. Select the logon tab and change the account starting the service to be an account that has access to the target directory.  If the target directory is on a share the account must have access to write to that share. 
  4. Restart the service and run the report again to verify that the distribution was successful. 
  • Verify that the directory entered was the correct full path to the location of the directory and not a mapped drive letter or any other varation.

 

Cause

  • The account starting NetIQ Core Services service does not have enough authority to write to the specified directory.  
  • The report failed and was not successful. 
  • The target directory was incorrectly entered into the path when specfying the distribution path.

Additional Information

Formerly known as NETIQKB72159