License error: Index was outside the bounds of array (NETIQKB72143)

  • 7772143
  • 11-Mar-2010
  • 11-Jan-2012

Environment

NetIQ Analysis Center 2.7 SP1+

Situation

AC2.7 SP1

Every time AC License Manager is open this error will show up. It will allow to continue but no licenses are listed.

Full error text:

at System.Globalization.DateTimeFormatInfo.InsertHash(TokenHashValue[] hashTable, String str, TokenType tokenType, Int32 tokenValue)
at System.Globalization.DateTimeFormatInfo.CreateTokenHashTable()
at System.Globalization.DateTimeFormatInfo.Tokenize(TokenType TokenMask, TokenType& tokenType, Int32& tokenValue, __DTString& str)
at System.__DTString.GetSeparatorToken(DateTimeFormatInfo dtfi)
at System.DateTimeParse.Lex(DS dps, __DTString& str, DateTimeToken& dtok, DateTimeRawInfo& raw, DateTimeResult& result, DateTimeFormatInfo& dtfi)
at System.DateTimeParse.TryParse(String s, DateTimeFormatInfo dtfi, DateTimeStyles styles, DateTimeResult& result)
at System.DateTimeParse.Parse(String s, DateTimeFormatInfo dtfi, DateTimeStyles styles)
at System.DateTime.Parse(String s)
at NetIQ.NQACApp.LicenseManager.UpdateTableKey()
at NetIQ.NQACApp.LicenseManager.LicenseManager_Load(Object sender, EventArgs e)

Resolution

Change the regional settings of the Operating System to use '$' currency character and also to use American date format.

Cause

Wrong Regional Settings in the Operating System will cause this, i.e: using an unknown currency character or using different dates separators and formats, etc. .

Additional Information

Formerly known as NETIQKB72143