The Send Email activity cannot send email (NETIQKB72042)

  • 7772042
  • 19-Jan-2010
  • 02-Sep-2011

Environment

NetIQ Aegis 2.1
NetIQ Aegis Exchange Adapter

Situation

The Send Email activity cannot send email
The Send Email activity cannot send an email, it fails immediately.
NetIQ Aegis Namespace Provider service fails when retrieving messages from the Exchange Server computer
The NetIQ Aegis Namespace Provider service fails when the Send Email activity executes during the course of a workflow.

Resolution

Why Install This Hotfix?

This hotfix resolves the following issues:

  • The Send Email activity cannot send email. Before you apply this hotfix, if the Send Email activity cannot send an email, it fails immediately. After you apply this hotfix, if the Send Email activity cannot send an email, it will try again a specified number of times. (ENG282694)
  • The NetIQ Namespace Provider service fails. Before you apply this hotfix, the NetIQ Aegis Namespace Provider service occasionally fails when retrieving messages from the Exchange Server computer. After you apply this hotfix, the NetIQ Aegis Namespace Provider service will not fail when retrieving messages from the Exchange Server computer. (ENG295118)  The NetIQ Aegis Namespace Provider service fails when the Send Email activity executes during the course of a workflow. (ENG296925)


Installing this Hotfix

To install this hotfix:

  1. Log on to the Aegis Server computer with a local administrator account.
  2. Run the AegisExchangeAdapter10_Hotfix72042.exe file.
  3. Follow the instructions in the wizard until you have finished installing the hotfix.
  4. The hotfix installation program automatically restarts the following Aegis services:
    • NetIQ Aegis Namespace Provider
    • NetIQ Aegis Engine
    • NetIQ Aegis Activity Broker
    • NetIQ Aegis Correlation Engine


Modified Files

This hotfix modifies the following files in the C:\Program Files\NetIQ\Aegis\IQConnect folder on the Aegis Server computer:

  • \bin\IQExchange.dll (Build Number 1.1.1.1)
  • \bin\IQExchange.map
  • \bin\IQExchange.pdb
  • \bin\IQEXMAPISupport.dll (Build Number 1.1.1.1)
  • \bin\IQEXMAPISupport.map
  • \bin\IQEXMAPISupport.pdb
  • \bin\NetIQExchange_1_4.dll (Build Number 1.0.1.2)
  • \bin\NetIQExchange_1_4.pdb
  • \pgapps\NetIQExchange_1_4\help\en-US\netiqexchange_getmailattachment.html
  • \pgapps\NetIQExchange_1_4\help\en-US\netiqexchange_sendmail.html
  • \pgapps\NetIQExchange_1_4\bin\NetIQExchange_1_4.dll (Build Number 1.0.1.2)

This hotfix adds the following files to the C:\Program Files\NetIQ\Aegis\IQConnect\Hotfixes\AegisExchangeAdapter_Hotfix72042 folder on the Aegis Server computer:

  • AegisExchangeAdapter10_Readme72042.htm
  • AegisExchangeAdapter10_Hotfix72042.log
  • Install.log


Known Issues

NetIQ Corporation strives to ensure our products provide quality solutions for your enterprise software needs. The following issues are currently being researched. If you need further assistance with any issue, please contact Technical Support:

Changing the Mail Profile Requires Manual Agent Restart.  After applying this hotfix, if you add a new account to the Mail applet in the Control Panel, you must manually restart the following services:

  • NetIQ Aegis Namespace Provider
  • NetIQ Aegis Correlation Engine

Cause

These issues are caused by a known limitation in the Exchange Adapter for NetIQ Aegis.

Additional Information

Formerly known as NETIQKB72042