How to disable auto list refreshing for an SCM console user. (NETIQKB72037)

  • 7772037
  • 18-Jan-2010
  • 06-Apr-2012

Environment

NetIQ Secure Configuration Manager 5.7

NetIQ Secure Configuration Manager 5.8

Situation

Unable to login to the SCM console completely with it hanging up and or freezing on me.

Resolution

If a customer is unable to access the tools\settings\Config and uncheck autorefresh enabled then a script will need to be run on the database.  The script requires that the id for the user from the SCM database be input before running the script.  To locate the PSUserID in the Vigilent Database under tables select the PSUsers Table and return all rows.  Locate the userid and corresponding ID number and replace the number in this script.


sp_SaveVigUserProperty @PSUserID = 123, @PropertyScope ='VSOCMisc' , @PropertyName = 'RefreshEnabled', @PropertyValue = 'false'

 

Cause

The refresh rate in SCM is set to 2 seconds by default which can cause a constant state of refresh if the lists are large.  The console will constantly send refresh requests and never complete a load of the screen since it is refreshing other screens at the same time.

Additional Information

Formerly known as NETIQKB72037