Context Menu in NetIQ Reporting Center does not display domain and OU choices. (NETIQKB71987)

  • 7771987
  • 24-Dec-2009
  • 18-Feb-2011

Environment

Directory & Resource Administrator 8.5
Directory & Resource Administrator 8.5 SP1
Directory & Resource Administrator 8.6

Situation

Context Menu in NetIQ Reporting Center does not display domain and OU choices.

AD collector jobs complete successfully, but event warnings (Event id 9006 from DRA server events in event logs).

Event ID 9006: Source AD Collector: Type: Event log Message: ADCollector completed collection for domain xyx.com from domain controller xyzdc01 with some warnings.

Reports contain no data.

The CONTEXTTABLEFOROU table in the DRAREPORTING database contains no data for a given domain.

Resolution

To resolve this issue, perform the following steps:

  1. Connect using SQL Management Studio, to the Database Engine of the SQL Server hosting the DRAReporting DB.
  2. Execute the following queries:
    • Truncate table dbo.CONTEXTTABLEFOROU
    • Get the Domain_ID from the domains table under DRAReporting Database. Note: Copy the EXACT value from the 'Name' field returned in the following query:

      Use draReporting
      select * from dbo.DOMAINS
    • Execute the following CONSTRUCTOUTREE procedure.
      -- Purpose: This Script is to populate the CONTEXTTABLEFOROU table manually
      -- Input:  Domain flat name
      -- Replace the domainname with the EXACT (Case Sensitive) Name from Query in step B. Note: Run this for every domain associated with the specified AD Collector jobs.

      DECLARE @DOMAINID INT
      SET @DOMAINID = (SELECT DOMAIN_ID FROM DOMAINS WHERE name = 'Domainname')
      PRINT @DOMAINID
      EXEC CONSTRUCTOUTREE 0,0,0,@DOMAINID

Cause

The CONTEXT table does not get populated.

Anti-virus is scanning the SQL db and log files, which puts the SQL server connection in an ?in-response? state.

Additional Information

Formerly known as NETIQKB71987

After changing the Domain name in the DRA Reporting DB, the new context will not show until the AD Collector runs successfully. Once the collector has ran, and the data has been uploaded into the SQL, the NRC Reports will show the correct context.

This problem will occur if the SQL server connection is in-response state, which can be caused by network connectivity and antivirus program issues. Consider excluding the SQL db and log files in the SQL installation folder to avoid the putting the SQL server connection in this state.