How do I enable logging for SCM Core Services? (NETIQKB71967)

  • 7771967
  • 11-Dec-2009
  • 14-Dec-2009

Environment

Secure Configuration Manager 5.8

Secure Configuration Manager 5.7

Secure Configuration Manager 5.6

Situation

How do I enable logging for the SCM Core Services service?

Resolution

To enable logging for Core Services logon to the machine where core services is installed and perform the steps below.

  1. Go to start\programs\NetIQ Secure Configuration Manager\Core Services Configuration Utility.
  2. In the Window that appears select the Logging tab.
  3. Change the Log Output Level to debug.
  4. Change the Communication Tracing to enabled.
  5. Then select Apply and OK.
  6. Go to Services and stop the NetIQ Core Services service and leave the services window open.
  7. Go to Windows Explorer to this directory %program files%\NetIQ\Secure Configuration Manager\Core Services\Log  and delete or rename the log files here. 
  8. Return to the Services window and start the NetIQ Core Services service.
  9. Recreate the issue so that it is captured in the log files. 
  10. Collect the logs at this location before any other settings are changed.  %program Files%\NetIQ\Secure Configuration Manager\Core Services\Log
  11. Go to start\programs\NetIQ Secure Configuration Manager\Core Services Configuration Utility
  12. Select the Logging tab and change the Log Output level to Information.
  13. Change the Communication Tracing to disabled.
  14. Open the Services window and stop and restart the NetIQ Core Services service. 
  15. Email the logs to support@netiq.com making sure to include the Service Request Number in the title. 

 

Cause

Logging is needed to increase the data written to the log files for troubleshooting.

Additional Information

Formerly known as NETIQKB71967

  • Ensure that logging for other involved components of SCM is enabled before recreating the issue.  
  • If the log files are too large to email please contact NetIQ Technical Support for FTP instructions.