Unable to install NetIQ Knowledge Base 2.0 on servers with .Net 2.0 or higher installed (NETIQKB71953)

  • 7771953
  • 30-Nov-2009
  • 04-Feb-2011

Environment

NetIQ Knowledge Base 2.0

Situation

Unable to install NetIQ Knowledge Base 2.0 on servers with .Net 2.0 or higher

If .Net 2.0 or higher is installed on a particular server, NetIQ KB 2.0 will fail to install properly

Unable to install NetIQ KB 2.0 on SQL 2005 server

Resolution

This can be worked around through a few simple changes in IIS Manager on the target server:

  1. In IIS Manager on the target system, open the Default Web Site properties
  2. Go to the ASP.NET tab, and make a note of the ASP.NET version that the Default Website is currently set to use
  3. You will need to change the Default Website to temporarily use .NET 1.1.
  4. Install NetIQ KB 2.0
  5. Once the install has completed successfully, return to IIS Manager
  6. Open the Default Web Site properties
  7. Go to the ASP.NET tab
  8. Reset the ASP.NET version of the Default Website to the original value that you noted in Step 2.

If you have further questions regarding this work-around, please contact NetIQ Technical Support for assistance.

Cause

The installer for NetIQ KB 2.0 will only work with .Net 1.1.  If a newer version of .Net is installed, the installer for NetIQ KB 2.0 will fail.

Additional Information

Formerly known as NETIQKB71953

This work-around is also detailed in the following Qmunity posting: https://community.netiq.com/forums/p/3428/10055.aspx#10055