Can not locate OnePoint during console or UI only install with user in reporting group (NETIQKB71940)

  • 7771940
  • 18-Nov-2009
  • 18-Nov-2009

Environment

Security Manager 6.0

Situation

Can not locate OnePoint during UI only install with non admin user
Consoles / UI's can not be installed using reporting user accounts

Resolution

What we need to do to fix this is to log into SQL Management Studio withan account that has SA rights (your admin account should do).  We then need to run the following SQL Query for each SM AD group.  You will need to change the AD groups to those seen in the Access Configuration tool of the central computer.

The example below should be modified to match your domain and AD groups.

This example is using Domain, "APAC" with four AD groups created for SM access rights.

-- ----------------------
use master
grant VIEW ANY DEFINITION to [APAC\SM Config Admins]
grant VIEW ANY DEFINITION to [APAC\SM Operators]
grant VIEW ANY DEFINITION to [APAC\SM Reporting]
grant VIEW ANY DEFINITION to [APAC\SM Users]
-- ----------------------

Cause

Security Manager 6.0 was checking for database access that should not be required for install.  This issue has been resolved in Security Manager 6.5.

If installation of the consoles is required by a non SQL server administrator, apply the changes to the SQL environment listed in the fix sectioh of this KB article.

Additional Information

Formerly known as NETIQKB71940

This issue is resolved in Security Manager 6.5.