Failed to start job, Invalid NULL kpc or worker (NETIQKB71937)

  • 7771937
  • 17-Nov-2009
  • 04-Feb-2011

Environment

NetIQ AppManager 7.0.x

Situation

Failed to start job, KS (Invalid NULL kpc or worker)

Resolution

Installation of the most recent QDB hotfix will prevent this from occuring in the future.

The only way to resolve the issue of jobs xxxxxxx is removing the Monitoring Policy (MP) from the computer group, waiting for all the jobs to stop, and reapplying the monitoring policy.  This will create new jobs and any associated AM reports may need to be recreated.

Cause

When removing an individual Agent from an existing Server Group which has a Monitoring Policy applied, an error in the Stored Procedure responsible for the processing of Monitoring Policies causes all job schedules in that Monitoring Policy to be removed from all Agents, instead of from the single intended Agent.

Additional Information

Formerly known as NETIQKB71937

To identify jobs that have a null KPC entry (scheduling issue) you can contact NetIQ Technical Support to obtain a SQL query.