Environment
Security Manager 5.6
Security Manager 6.X
Situation
Control Center Opens with Red X's
Resolution
The property bag for a user is the data in the database that is relevant to that users login. An easy way to address this is to delete the property bag of the affected user. This data can safely be deleted, as it only stores preferences:
- Close all instances of Control Center for Security Manager
- Open SQL Management Studio
- Connect to the Database Engine
- Click on the New Query button at the top left of SQL Management Studio
- Run the following 2 select statements (change the DOMAIN\USER to the domain\user of the affected Control Center user account):
- use securitymanagercommon
select pbi.*
from propertybag pb
join propertybagitem pbi on (pb.idpropertybag = pbi.idpropertybag)
where pb.username = 'DOMAIN\USER' - use securitymanagercommon
select pb.*
from propertybag pb
where pb.username = 'DOMAIN\USER'
- use securitymanagercommon
- If data is returned, then execute the following 2 delete statements (change the DOMAIN\USER to the domain\user of the affected Control Center user account):
- use securitymanagercommon
DELETE pbi
FROM propertybag pb
join propertybagitem pbi on (pb.idpropertybag = pbi.idpropertybag)
where pb.username = 'DOMAIN\USER' - use securitymanagercommon
DELETE propertybag
where username = 'DOMAIN\USER'
- use securitymanagercommon
- Reopen Control Center and validate that the change made addressed the issue.
Cause
Sometimes the property bag for the user can become corrupted
Additional Information
Formerly known as NETIQKB71861