No Database Connection is made in NRC. Unable to make database connection. (NETIQKB71847)

  • 7771847
  • 23-Sep-2009
  • 17-Nov-2011

Environment

Directory & Resource Administrator 8.5x
Directory & Resource Administrator 8.6x

NetIQ Reporting Center 1.0
NetIQ Reporting Center 1.5

Situation

No Database Connection is made in NRC. Unable to make database connection.

Resolution

Logon to the DRA Server with the user configured in the DRA Reporting Service Configuration

Run the following commands on command prompt
 XmlCheckIn.exe /S <SQL Server Name> DRA.DataSourceType.XML
 XmlCheckIn.exe  /S <SQL Server Name> DRA.UDContext.xml
 XmlCheckIn.exe  /S <SQL Server Name> DRA.ExtDataSource.XML
 XmlCheckIn.exe  /S <SQL Server Name> DRA.Report.XML

Reopen the NRC console, verify the Database connection.

 

 or SQL Server from which the DRAReporting was run

Locate the two files DRA.ExtDataSource.XML and XmlCheckIn.exe.config

 

C:\Program Files\NetIQ\Reporting Center\bin

Edit both files, and replace Server="Localhost" with Server="SQL SERVER name"

Logon to the DRA Server -- Connect as a user with Local Admin Rights on DRA AND DB_Owner rights over the SQL Database AC_Configuration

From command prompt go to the NRCReporting folder
Run the following commands on command prompt
 XmlCheckIn.exe DRA.DataSourceType.XML
 XmlCheckIn.exe DRA.UDContext.xml
 XmlCheckIn.exe DRA.ExtDataSource.XML
 XmlCheckIn.exe DRA.Report.XML
Reopen the NRC console, verify the Database connection.

Cause

During the setup of DRA & NetIQ Reporting Center, DRA attempts to populate SQL with information about the NRC & DRA. If there is a communication issue during setup or other issues impacting the SQL setup, NRC will often fail to regonize the correct database. DRA has a command-line utility to manually update various tables within SQL. When opening the NRC, the Database connection will be blank.

Additional Information

Formerly known as NETIQKB71847