Environment
AppManager 7.x
Situation
Unable to install a Control Center hotfix. Fails pre-check for SQL with error "Unable to determine SQL Edition. SQL Server may not be running or user may not have permission to login."
Resolution
In order to correct the problem described above please perform the steps below:
Check the following registry key on the Control Center Repository:
HKLM | SOFTWARE | NETIQ | AppManager | Control Center | 1.0 | CCDB {SQLServer}:
The value for the SQLServer should not be a null or 0 but the SQL SERVER hostname. If the value is null or 0 update the value to specify the name of the SQL Server.
Once the above step has been performed the hotfix will install successfully.
Cause
This problem is caused if the SQLServer value is either NULL or 0 in the Registry on the Control Center machine under:
HKLM | SOFTWARE | NETIQ | AppManager | Control Center | 1.0 | CCDB {SQLServer}: