Environment
We have found an issue where CGW does not clean up properly when a file is unsuccessfully opened. This is a common occurrence on an exchange server, and we feel this fits the symptom of the performance issue that occurs in these environments. This is further impacted in Exchange 2003 servers where the 3GB switch has been enabled.
Situation
Resolution
The only known fix currently is to exclude the affected computer from the CGW computer group in the Security Manager Dev Console. Then go to add remove programs on the machine affected, and reinstall the CGW provider from the machine. The last step is as soon as possible to a reboot of the server so the agent components in the memory will be removed.
To validate that the CGW drive is no longer loaded, execute the driverquery command from a command prompt, and then validate that cgw is no longer resident in memory.
Cause
We have found an issue where CGW does not clean up properly when a file is unsuccessfully opened. This is a common occurrence on an exchange server, and we feel this fits the symptom of the performance issue that occurs in these environments. This is further impacted in Exchange 2003 servers where the 3GB switch has been enabled.
Additional Information
Currently, the upcoming SP1 for CGW 2.0 does not show this as addressed in the SP, however, we do feel like we will either substantially improve the situation or resolve it with this release.