Error: Failed to start log archive service. (NETIQKB71819)

  • 7771819
  • 14-Sep-2009
  • 19-Dec-2013

Environment

Directory & Resource Administrator 8.5
Directory & Resource Administrator 8.5 SP1
Directory & Resource Administrator 8.6
Directory & Resource Administrator 8.6 SP1

Situation

Failed to start log archive service.

Error during DRA 8.5 install or upgrade: "Failed to start log archive service."

Resolution

Please follow the below steps to install DRA Server and Log Archive Service manually:

(Note: Fore DRA 8.6 and later, begin at step 2.)

1. Replace 'NetIQAdmin.msi' file available in "8.50.00 Installation > Intel" folder  and run setup.exe to install DRA without Log Archive Service.

2. Complete the installation of DRA. Once DRA installation is over,verify that "installation directory\Program Files\NetIQ\DRA\NetIQLogArchiveData"exist. Next  edit the "path" value in LogArchiveConfiguration.config file. Note: The LogArchiveConfiguration.config file will be present under "C:\ProgramData\NetIQ\Directory Resource Administrator\LogArchiveConfiguration.config" [For Windows 2008 operating system or higher] and "C:\Documents and Settings\All Users\Application Data\NetIQ\Directory Resource Administrator\LogArchiveConfiguration.config" [For Windows 2003]


3. Open LogArchiveConfiguration.config file using notepad and search for the below line
 <VolumeSettings name="Logvolume" path="E:\Program Files\NetIQ\DRA\NetIQLogArchiveData" maxSizeInBytes="1833783296" />
 In that line, replace the text path="E:\Program Files\NetIQ\DRA\NetIQLogArchiveData" to the path where Log Archive datafiles to be generated. Please make sure that the mentioned path exists in the system. Save and close the config file.

4. Install Log Archive Service by running the following command in the command prompt.
"C:\Program Files (x86)\NetIQ\DRA\NetIQLogArchive\DotNetInstaller.exe "C:\Program Files (x86)\NetIQ\DRA\NetIQLogArchive\NqLogArchiveServer.exe""
5. When it prompts for the User Name and Password. Please provide <DomainName>\<UserName> format in the User Name field and the password in password field.

6. Once the installation is done, go to services panel and start the Log Archive Service.

 

Cause

The path for the install of the log archive service files on a 64bit machine is defaulting to the "Program Files (x86)" directory instead of "Program Files".

The install path is not local. LAS will not work with NAS, Filer or mapped drive locations.

Additional Information

Formerly known as NETIQKB71819
Formerly known as NETIQKB72406