Error: Unable to upload aggregate data to SMCubeDepot database (NETIQKB71813)

  • 7771813
  • 10-Sep-2009
  • 09-Feb-2011

Environment

Directory and Resource Administrator 8.5
Directory and Resource Administrator 8.5 SP1
Directory and Resource Administrator 8.6
Directory and Resource Administrator 8.6 SP1

Situation

Error: Unable to upload aggregate data to SMCubeDepot database . Please check availability of connection. Details: Cannot open database "SMCubeDepot" requested by login. The login failed.

Event ID: 1019

SMCubeDepot database is not created.

Resolution

The SMCubeDepot database is only created when the DRARepoting.msi is run.  The DRAReporting.msi is not automatically initiated after an upgrade or install of Directory and Resource Administrator (DRA) 8.5 or latter from either of the setup.exe files.

Upgrading or installing DRA 8.5 or latter with the new Reporting component is a two-step process in any upgrade or installation scenario.  After running the setup.exe file which will install DRA, the DRAReporting.msi must also be run. The DRAReporting.msi is located in the NetIQAdminSetup directory once you run the AdminInstallationKit.exe file.

To resolve this issue, run the DRAReporting.msi which will create the SMCubeDepot database in SQL.

Because DRA does not support a remote install of Reporting, this file must also be run on any remote machine SQL is installed on and being used by the DRA Reporting component.

Cause

The SMCubeDepot database has not been created. Attempts to connect to it generate Event ID 1019 errors.

The SMCubeDepot database in inaccessiable via ODBC calls to the SQL server hosting the Netiq Reporting Center for DRA.

Additional Information

Formerly known as NETIQKB71813