Environment
NetIQ AppManager 6.x
NetIQ AppManager 7.0.x
Situation
General_EventLog is generating an event of:
Rerr4133(L312) ReadEvent Failed LastCode 0
Rerr4133(L312) ReadEvent Failed
Resolution
In order to rectify the problem you can perform the following steps on the agent machine.
Modify the following registry key to delay the MC jobs from starting for a few seconds to prevent this error:
HKEY_LOCAL_MACHINE\SOFTWARE\NETIQ\AppManager\4.0\netiqmc\config\StartupDelay = "15" (Decimal)
This registry key is defaulted to this value in more recent releases of AppManager.
Cause
This error typically occurs when machines running the AppManager Agents are rebooted. The AppManager Agent service and Eventlog jobs are starting before the Windows Eventlog service has started.
Additional Information
Formerly known as NETIQKB71804