How do I manually remove orphaned jobs from the QDB? (NETIQKB71798)

  • 7771798
  • 04-Sep-2009
  • 16-Dec-2010

Environment

NetIQ AppManager 6.x
NetIQAppManager 7.0.x

Situation

Application Event Logs on the Management Server machine log entries stating that Orphaned Jobs are present in the Repository (QDB)
How do I manually remove orphaned jobs from the QDB?

Resolution

If the agent is still on line and can be reached, you should use the NetIQSync tool that is shipped with AppManager.  You can find this tool in the extracted installation files, typically in the following path:

    • C:\Program Files\NetIQ\Windows_Installation\Extras\Utilities\AppManager Tools

This executable must be run from the command prompt, and a full list of the switches available can be gathered by executing the program followed by /?

If the NetIQSync tool is unable to reach the agent or remove the jobs, proceed to the next steps.

Locate the Job ID's regarding the orphaned jobs, you can gather this information from the events generated in the event log, or by locating the orphaned job in the console and referencing the Job ID from there.  Once you have the job id's for the parent and child jobs, proceed with the following:

  1. From SQL Query Analyzer or by initiating a New Query run the following query populating the xxxxx with the job id that is orphaned: 
    • Update job set status = 134217728 where jobid = xxxxx
      • Repeat this process for each parent and child job that is orphaned
  2. From SQL Query Analyzer or by initiating a New Query run the following statement directed at the QDB:
    • EXEC Task_Daily
  3. From the Operator Console or Control Center Console, refresh the Jobs view, or close and reopen the console and very the jobs have been removed.

Cause

Jobs that are improperly removed from servers can become orphaned jobs and reside in the QDB while no longer being present on the managed client.  To properly remove a job, the job should be allowed to stop, and then be deleted via the Operator Console or Control Center Console.

Additional Information

Formerly known as NETIQKB71798

The above process makes changes directly to your AppManager Repository.  Thus,  we strongly recommend ensuring that you have a full backup of the Repository database before making any changes.