Log files on the Agent machines have ODBC and SQLSTATE=01004 error messages (NETIQKB71727)

  • 7771727
  • 20-Aug-2009
  • 15-Dec-2010

Environment

NetIQ AppManager 6.x
NetIQ AppManager 7.0.x

Situation

Error:cmdb-load: oper abort, err=<[CMEvent]: repository error
SQLSTATE=01004, NativeErr=5, msg=<[Microsoft][ODBC Microsoft Access Driver]String data, right truncated on column number 22 (AgentMsg)>
ODBC error generated consistently in the CCMTrace.log on an agent.

Resolution

In order to resolve the issue described above, please perform the following steps on the Agent machine:

  1. Stop the NetIQ AppManager Client Communications Manager and the NetIQ AppManager Client Resource Monitor on the client machine.
  2. Copy a local repository from another agent that is not experiencing the issue over top of the existing repository on the client machine.
    • The default location of the repository is C:\Program Files\NetIQ\AppManager\db
  3. Restart the agent services using a -O (and in Oscar) parameter.

Cause

The above errors may occur if a column in the local repository on the Agent machine corrupt and is truncating entries.

Additional Information

Formerly known as NETIQKB71727