Environment
Security Manager 6.x
Security Manager 5.x
Situation
Resolution
In order to address this issue, you will need to remove some extraneous information from the database. Follow these steps to resolve the issue:
- Stop the NetIQ Security Manager service on all Central Computers
- Open SQL Server Management Studio on your OnePoint database server
- Once connected, click the New Query button at the top left of the Management Studio window.
- Run the following command
- use onepoint
delete from computersecurity where status > 7999
- use onepoint
- Start the NetIQ Security Manager service on all Central Computers
Cause
In some instances there is a problem with some data in the configuration database that Security Manager depends upon. In this instance you are seeing a problem with the type of data available in the computersecurity table in the OnePoint database, which is causing these 2 errors to appear:
An attempt to import cryptographic key failed. Error details: Bad Version of provider.. Key length: 604
The central computer failed to obtain its authentication keys from the database. The central computer cannot communicate with agents until it obtains its keys. If this problem persists, please contact NetIQ Technical Support.