Central Computer unable to retrieve authentication keys from the database. (NETIQKB71717)

  • 7771717
  • 18-Aug-2009
  • 10-Sep-2009

Environment

Security Manager 6.x

Security Manager 5.x

Situation

Central Computer unable to retrieve authentication keys from the database. Import of cryptographic key failed

event id 21294

event id 21324

Resolution

In order to address this issue, you will need to remove some extraneous information from the database. Follow these steps and this issue should be resolved:

 

  1. Stop the NetIQ Security Manager service on all Central Computers
  2. Open SQL Server Management Studio on your OnePoint database server
  3. Once connected, click the New Query button at the top left of the Management Studio window.
  4. Run the following command against the OnePoint database
    • use onepoint delete from computersecurity where status > 7999
  5. Start the NetIQ Security Manager service on all Central Computers.

Cause

An attempt to import cryptographic key failed.    Error details: Bad Version of provider..  Key length: 604 

The central computer failed to obtain its authentication keys from the database.   The central computer cannot communicate with agents until it obtains its keys.    If this problem persists, please contact NetIQ Technical Support. 

Additional Information

Formerly known as NETIQKB71717