Install of SP3 failing with MSDTC issue even with MSDTC configured as required. (NETIQKB71692)

  • 7771692
  • 11-Aug-2009
  • 13-Aug-2009

Environment

Security Manager 6.0 SP3
Security Manager 6.0 SP4

Situation

Install of Service Pack failing with MSDTC issue even with MSDTC configured as required.

Resolution

1)  Remove MSDTC:
-  Run "services.msc"
-  Stop the service "Distributed Trasaction Coordinator"
-  Open a command prompt.
-  Run the command "msdtc -uninstall"
-  Confirm this service is removed by refreshing the services screen.

2)  Clear registry:
-  Run "regedit"
-  Browse to and delete the keys below if they exist:
--  HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MSDTC
--  HKLM/System/CurrentControlSet/Services/MSDTC
--  HKEY_CLASSES_ROOT\CID

3)  REBOOT

4)  Reinstall MSDTC:
-  Open a command prompt.
-  Run the command "msdtc -install"
-  Start the newly added service "Distributed Trasaction Coordinator"

5)  REBOOT the machine

6)  Reconfigure MSDTC:
-  Using section 1 of NETIQKB71176, reconfigure MSDTC.
--  https://www.netiq.com/KB/NETIQKB71176

After this is completed, please attempt to install SP3 or SP4 again on this machine.

Cause

Security Manager uses MSDTC for communication between the central computers and the database.  MSDTC must be manually configured to install SP3 or SP4.

 

Additional Information

Formerly known as NETIQKB71692