Environment
NetIQ Appmanager 6.x
Situation
NetIQ AppManager Client Communication Manager does not send Data or Events
The mctrace.log shows the following error(s):
getMapNextPos: trying to wake up the reader to drain the queue
putMapNextRec: out of space for map record
commcenter-cSend: failed to write
The ccmtrace.log logs the following entries over and over:
1243890432 [4492] svcmon: Checking up on service NetiqMc at 1800000 millisec intervals.
1243890432 [4492] Index: 0 (Number of Entries) LongValue: 5 StringValue:
1243890432 [4492] Index: 1 (Should Restart) LongValue: 1 StringValue:
1243890432 [4492] Index: 2 (Number of Restarts) LongValue: 1 StringValue:
1243890432 [4492] Index: 3 (Average Restart Time) LongValue: 0 StringValue:
1243890432 [4492] Index: 4 (Last Start Time) LongValue: 1243364702 StringValue: Tue May 26 15:05:02 2009
No Data or Events show up for an agent in the console.
Resolution
You should not need to cold start the NetIQ AppManager Client Communication Manager under normal circumstances. However, should you need to cold start the NetIQccm service, use the -o option to avoid this problem.
If you do cold start the NetIQccm service with the -oa, then you should also restart the NetIQ AppManager Client Resource Monitor (NetIQmc) service to avoid this problem. To correct the issue if the agent is already in this state, restart (Stop & Start) the NetIQ AppManager Client Resource Monitor (NetIQmc) on the machine in question.
Cause
If the NetIQ AppManager Client Communication Manager (NetIQccm) service is cold started using the -oa option, the CMComm table in the agent's Local Repository is cleared. This essentially clears the site information of the AppManager environment that the NetIQccm relies on to operate normally.