Dell OpenManage Discovery fails with error (NETIQKB71562)

  • 7771562
  • 18-May-2009
  • 01-Oct-2018

Environment

NetIQ AppManager 6.x
NetIQ AppManager 7.x
NetIQ AppManager 8.x
Dell OpenManage Module

 


Situation

Dell OpenManage Discovery fails with error
Dell OpenManage Discovery fails with 'Dell Discovery Failed. Verify that the computer is a dell server and that is the correct SNMP community name.'

Resolution

Please perform the following checks, to attempt to correct this issue:
  1. Verify the security settings for the SNMP service are correct (Start -> Run -> services.msc)
    1. Right+Click on the SNMP Service and select the Security Tab
    2. Verify the SNMP community name is correct and that at least Read permissions have been granted.
    3. Verify that you have allowed SNMP packets to be accepted from the local machine (the hostname must be specified, localhost is not sufficient)

  2. Verify all Dell OpenManage Services are running (Only valid if DSM services are installed) (Start -> Run -> services.msc)
    1. DSM SA Event Manager Service
    2. DSM SA Connetion Service
    3. DSM SA Data Manager Service
    4. DSM SA Shared Services

  3. Use snmpwalk.exe in order to verify snmp is configured correct and to check the Dell MIBs availability. (http://www.net-snmp.org/download.html)

    Note that snmpwalk must be executed from the command line with Start -> Run -> cmd

  4. Start with a simple test to ensure snmp is working correctly

    • snmpwalk -v2c -c <community_name> <localhost> .1.3.6.1.2.1 > C:\snmpwalk_simple.txt 

      If the above is successful, check Dell MIB

    • snmpwalk -v2c -c <community_name> <localhost> .1.3.6.1.4.1.674 > C:\snmpwalk_dell.txt

      Where <public> is the name of the <community_name> and <localhost> is the name of the server

  5. If snmpwalk_dell.txt contains data and you are still unable to successfully discovery the Dell OpenMange MO please contact NetIQ Technical Support

  6. If snmpwalk_dell.txt from the snmpwalk above is blank then the snmpwalk was unable to successfully check the Dell MIB's or return for the queried OID's

    • Please verify snmp security as explained in step 2

    • If you have verified that snmp security is configured correctly, try to run the following from the command line
      • snmpwalk -v2c -c <public> <localhost>

        where <public> is the name of the community string and <localhost> is the name of the server.  If no results are returned then snmp is not configured correctly or the snmp service is not running.  You will not be able to discover the Dell OpenManage MO if the snmpwalk returns 0 results

  7. If you have verified that you are able to return results using snmpwalk -v2c -c <public> <localhost> however do you return any results when following Step 4 then the Dell MIB's were not loaded correctly while installing Dell OpenManager or the Dell OpenManage installation was corrupt

    If you have determined that your Dell OpenManage installation is corrupt please try the following

    1. Open Manage console and check information in the system
    2. Open registry editor (Start -> Run -> regedit) and browse to HKLM\SYSTEM\CurrentControlSet\Services\SNMP\Parameters\ExtensionAgents
      • Check to see if the SysMgmtDataEngine key exists with a value of: SOFTWARE\Dell Computer Corporation\OpenManage\DataEngine\SNMP Agent\CurrentVersion (if the key does not exist or the data is not correct then you will need to manually add this key and the correct associated data)
      • Restart all four Dell OpenManage Services (only valid if DSM services are installed)
      1. DSM SA Connection Service
      2. DSM SA Data Manager
      3. DSM SA Event Manager
      4. DSM SA Shared Services
      • Restart SNMP as well (this will restart DSM and HP CIM services)
    3. Re-run snmpwalk.exe following the insturctions in Step 4.  If the results return successful then you should be able to successfully discover the Dell OpenManage MO
    4. If still not working, Uninstall/Reinstall Dell OpenManage and then SNMP
    5. Once Dell OpenManager and SNMP have been reinstalled, Run these basic OID queries
      1. Basic OID query to have servername
        • nqsnmp -a <computername> -c <Community_Name> -I .1.3.6.1.2.1.1.5.0
      2. OID query on Dell
        • nqsnmp-a <computername> -c <Community_Name> -I .1.3.6.1.4.674.10892.1.100.4.0
    6. If query on OID on Dell is OK, you should be able to successfully discover the Dell OpenManager MO

Cause

There are several possible causes that will result in failed discovery of the Dell OpenManage MO.

 

Additional Information

Formerly known as NETIQKB71562