Web Console fails to find computer that has dashes in name. (NETIQKB71473)

  • 7771473
  • 17-Feb-2009
  • 03-Feb-2011

Environment

NetIQ AppManager 7.0.x

Situation

Web Console fails to find computers that have dashes in name.

Resolution

In order to correct these issues, you will need to download and install AppManager 7.0.1 Hotfix 71473.  The Hotfix has been made available at the following location:

https://www.netiq.com/f/downloads/download.asp?id=1F481C3A-C40D-432F-B814-FAEDA92CE4F4

Why Install This Hotfix?

This hotfix resolves the following Web management server issues:

  • Resolves an issue with job creation for the General, NT, and NTAdmin Knowledge Script categories. When you click Create New Job and select a Knowledge Script from any of those categories, Internet Explorer displays the following message (ENG235115):

Internet Explorer cannot display the web page.

  • Resolves an issue with viewing events in dynamic views. If a dynamic view has one open event and you select the event, the Operator Web Console shows that no open events exist for that view. If you refresh the page, the Operator Web Console shows that the view has an open event. (ENG257022)
  • Resolves an issue with access to views on the Operator Web Console. If you use Security Manager to grant a Windows user group access to specific views, the group members have access to all views. If you use Security Manager to grant individual users access to specific views, the users have access to only the views you specify. (ENG258604)
  • Resolves an issue with exporting chart data. Before you apply this hotfix, if you export two data streams with a different number of data points to create a chart, the Operator Web Console repeats data points from the shorter stream until the streams are the same length. After you apply this hotfix, the Operator Web Console displays N/A to indicate gaps between the data points for combined data streams. (ENG258606)
  • Resolves an issue with refreshing charts. If a chart has two data streams and one of the streams has data points with 0 values where the other has data points with non-zero values, when you move the streams, the Operator Web Console does not refresh the 0 values. Instead, it doubles the values of the corresponding data points from the other stream. (ENG258610)
  • Resolves an issue where the Operator Web Console fails to find computers when the computer name contains multiple dashes. Internet Explorer displays the following message (ENG259957):

Computer computer name doesn't exist.

  • Resolves an issue where data streams for computers with names containing multiple dashes are not available for selection when creating charts on the Operator Web Console. (ENG261487)

  • Resolves an issue with viewing XML event details on the Operator Web Console. When you select an XML event to view details, you must scroll to view the detailed message. (ENG262019)
  • Resolves an issue where the Operator Web Console does not display X- and Y-axis values for charts in Microsoft Windows Vista and Microsoft Windows Server 2008 environments. (ENG262033)
  • Resolves an issue with IP addresses in VoIPQuality reports. Before you apply this hotfix, the Operator Web Console displays only the first segment of IP addresses in VoIPQuality reports. To fully resolve this issue, you must also apply Hotfix 71472 on the Windows agent computer. After you apply Hotfix 71472 on the Windows agent computer, you can successfully generate VoIPQuality reports from the Operator Web Console. (ENG262054)
  • Resolves an issue where the Operator Web Console does not display the first chart that a new user creates, but displays all subsequent charts that the user creates. (ENG264122)

For more information about the issues resolved with this hotfix, see NetIQ Knowledge Base article NETIQKB71473.

Contents of the Download Package

The download package contains the following files, which are used by the hotfix setup program unless otherwise noted:

  • AM701_Hotfix71473_Setup.exe, the hotfix setup program.
  • BaseInstall.dll
  • MFC71u.dll
  • msvcp71.dll
  • msvcr71.dll
  • Patch.ini
  • AM701_ReadMe71473.htm, this readme.
  • Setup Files, a folder that contains AM701_Hotfix71473_WMSSetup.msp, the Web management server setup program. The hotfix setup program automatically runs this file to update the Web management server.

Installing This Hotfix

To install this hotfix, run AM701_Hotfix71473_Setup.exe on all Web management server computers.

The PATCH.log file lists all changes and problems encountered during the installation process. The Windows installer log file, AM701_Hotfix71473_WMSSetup.msp.log, lists only the changes associated with the hotfix installation. By default, these files are located in the \NetIQ\Temp\NetIQ_Debug folder.

Modified Files

This hotfix modifies the following files on all Web management server computers:

  • AMChart.asp (Build Number 7.0.11258.0)
  • AMWebConHelp.asp (Build Number 7.0.11258.0)
  • AutoLogin.asp (Build Number 7.0.11258.0)
  • autologinevent.asp (Build Number 7.0.11258.0)
  • autologinreports.asp (Build Number 7.0.11258.0)
  • ChildEventList.asp (Build Number 7.0.11258.0)
  • ChildrenJobFrame.asp (Build Number 7.0.11258.0)
  • computerdetailsframe.asp (Build Number 7.0.11258.0)
  • customproperties.asp (Build Number 7.0.11258.0)
  • delete_machine_and_group.asp (Build Number 7.0.11258.0)
  • group_checkboxes.asp (Build Number 7.0.11258.0)
  • machine_checkboxes.asp (Build Number 7.0.11258.0)
  • manipulate_groups.asp (Build Number 7.0.11258.0)
  • move_machine_and_group2.asp (Build Number 7.0.11258.0)
  • new_job_wizard4.asp (Build Number 7.0.11258.0)
  • ParentEventList.asp (Build Number 7.0.11258.0)
  • portal.asp (Build Number 7.0.11258.0)
  • Portalchildreneventframe.asp (Build Number 7.0.11258.0)
  • topmenu.asp (Build Number 7.0.11258.0)
  • tree.asp (Build Number 7.0.11258.0)
  • component.dat (Build Number 7.0.11258.0)
  • AMChartSet.dll (Build Number 7.0.11258.0)
  • AMChartWiz.dll (Build Number 7.0.11258.0)
  • AMLAYOUT.dll (Build Number 7.0.11258.0)
  • AMOLAPUtilities.dll (Build Numbe 7.0.11258.0)
  • AMVerCheck.dll (Build Number 7.0.11258.0)
  • LFCMP12n.DLL (Build Number 7.0.11258.0)
  • Lfpng12n.dll (Build Number 7.0.11258.0)
  • LTDIS12n.dll (Build Number 7.0.11258.0)
  • ltfil12n.dll (Build Number 7.0.11258.0)
  • ltkrn12n.dll (Build Number 7.0.11258.0)
  • Ltwvc12n.dll (Build Number 7.0.11258.0)
  • mfc42.dll (Build Number 7.0.11258.0)
  • MFC71.dll (Build Number 7.0.11258.0)
  • MSVCP60.DLL (Build Number 7.0.11258.0)
  • msvcp71.dll (Build Number 7.0.11258.0)
  • msvcr71.dll (Build Number 7.0.11258.0)
  • NetIQ_ENU.dll (Build Number 7.0.11258.0)
  • NETIQFILTERS.dll (Build Number 7.0.11258.0)
  • NetIQLic.dll (Build Number 7.0.11258.0)
  • netiqole.dll (Build Number 7.0.11258.0)
  • netiqole65.dll (Build Number 7.0.11258.0)
  • NETIQREPORT.dll (Build Number 7.0.11258.0)
  • NETIQXL.dll (Build Number 7.0.11258.0)
  • AMChartCon.exe (Build Number 7.0.11258.0)
  • NetIQGraphics.exe (Build Number 7.0.11258.0)
  • NeTQAMChartComponent.exe (Build Number 7.0.11258.0)
  • CachedRecordset.inc (Build Number 7.0.11258.0)
  • chart_resource.inc (Build Number 7.0.11258.0)
  • genericfunctions.inc (Build Number 7.0.11258.0)
  • sqlquery.inc (Build Number 7.0.11258.0)
  • default.inf (Build Number 7.0.11258.0)
  • AMChart.ocx (Build Number 7.0.11258.0)
  • AMChartHost.ocx (Build Number 7.0.11258.0)
  • AMChartLite.ocx (Build Number 7.0.11258.0)
  • netiqreports.reg (Build Number 7.0.11258.0)

Cause

Known issues with the NetIQ AppManager 7.0.x Web Management server.

Additional Information

Formerly known as NETIQKB71473

Contacting NetIQ Corporation

Please contact us with your questions and comments. We look forward to hearing from you.

Sales Email:

info@netiq.com

Telephone:

1-713-418-5555 (United States)
+353 (0) 91-782-677 (Europe, Middle East, and Africa)
For other locations, see our Support Contact Information Web site at
www.netiq.com/support

Support Web Site:

www.netiq.com/support