Incorrect computer ID for AppManager proxy events in NetIQ Aegis 2.0 (NETIQKB71446)

  • 7771446
  • 21-Jan-2009
  • 01-Sep-2011

Environment

NetIQ Aegis 2.0

Situation

Incorrect computer ID for AppManager proxy events in NetIQ Aegis 2.0


NetIQ Aegis 2.0 generates a Syntax error in the iqamGetRepositoryInfo stored procedure

NetIQ Aegis 2.0 AppManager Adapter has a memory leak

The iqamInsertUpdateObjectProp stored procedure does not load correctly on NetIQ Aegis 2.0 upgrade installs.

Resolution

Hotfix 71446 for NetIQ Aegis 2.0 has been released to correct these issues.  You should install this Hotfix using the instrucitons provided in this article, or in the Readme file tha tis included in the Hotfix package.  You can download the Hotfix from the following location:

https://www.netiq.com/f/downloads/download.asp?id=12536750-170A-4169-B067-F858192E57C6

Why Install This Hotfix?

This hotfix resolves the following issues related to the NetIQ Aegis Adapter for NetIQ AppManager (AppManager adapter):

  • Incorrect computer ID for AppManager proxy events. Before you apply this hotfix, if you select the Display AM Proxy Events as objects in treeview check box on the Properties window in the AppManager Operator Console, and then run a job that monitors computers for proxy events, such as the General_MachineDown job, proxy events contain the computer ID of the computer running the job instead of the computer that generated the proxy event. After you apply this hotfix, proxy events contain the computer ID of the computer that generated the proxy event. (ENG259053)
  • Syntax error in the iqamGetRepositoryInfo stored procedure. Before applying this hotfix, when you use the Adapter Configuration Utility to to load stored procedures into a QDB, the iqamGetRepositoryInfo stored procedure fails and returns an error. After you apply this hotfix, the iqamGetRepositoryInfo stored procedure loads into the QDB correctly. (ENG259640)
  • Memory leak in the AppManager adapter. Before you apply this hotfix, a slow memory leak in the AppManager adapter eventually causes the NetIQ Aegis Namespace Provider service to shut down. After you apply this hotfix, the AppManager adapter correctly releases allocated memory. (ENG259090)
  • Stored procedure not loaded into QDB. Before you apply this hotfix, if you upgraded to Aegis 2.0 using the 2.0 Upgrade installer, when you use the Adapter Configuration Utility to to load stored procedures into a QDB, the iqamInsertUpdateObjectProp stored procedure does not load. After you apply this hotfix, the iqamInsertUpdateObjectProp stored procedure loads into the QDB. (ENG259927)
  • Aegis resource hierarchy does not display AppManager QDBs. Before you apply this hotfix, when you use the Adapter Configuration Utility to add QDBs to Aegis, the resource hierarchy in the Configuration Console does not display the new QDBs. After you apply this hotfix, the resource hierarchy correctly displays new QDBs. (ENG260173)

Installing This Hotfix

Complete the following steps to install this hotfix:

  1. Log on to the Aegis Server computer with a local administrator account.
  2. Run the Aegis20_Hotfix71446.exe file.
  3. Follow the instructions in the wizard until you have finished installing the hotfix.

The hotfix installation program automatically restarts the following Aegis services:

  • NetIQ Aegis Namespace Provider
  • NetIQ Aegis Engine
  • NetIQ Aegis Activity Broker
  • NetIQ Aegis Correlation Engine

Modified Files

This hotfix modifies the following files in the IQConnect folder on the Aegis Server computer, by default C:\Program Files\NetIQ\Aegis\IQConnect:

  • \bin\NetIQGeneric_1_2.dll (Build Number 2.0.1.265)
  • \pgapps\NetIQGeneric_1_2\bin\NetIQGeneric_1_2.dll (Build Number 2.0.1.265)
  • \bin\NetIQGeneric_1_2.pdb
  • \pgapps\NetIQGeneric_1_2\help\en-US\netiqgeneric_runcommand.html

This hotfix adds the following files to the C:\Program Files\NetIQ\Aegis\IQConnect\HotFixes\Aegis20_Hotfix71444 folder on the Aegis Server computer:

  • Aegis20_Hotfix71446.log
  • Aegis20_Readme71446.htm

Cause

Several known issues within the NetIQ Aegis 2.0 product.

 

Additional Information

Formerly known as NETIQKB71446

Contact Information

Please contact us with your questions and comments. We look forward to hearing from you.

For detailed contact information, see the Support Contact Information Web site .