Aegis Server Run Command activity fails to interpret quotation marks correctly. (NETIQKB71444)

  • 7771444
  • 19-Jan-2009
  • 01-Sep-2011

Environment

NetIQ Aegis 2.0

Situation

If you use double quotes in the Argument parameter on the Run Command on Aegis Server Computer activity, the activity fails at run time.


The Run Command on Aegis Server activity does not correctly interpret double quotes (") in the Arguments parameter

Resolution

This issue is resolved by Hotfix 71444 for NetIQ Aegis 2.0.  You can obtain a copy of this Hotfix from the following location:

https://www.netiq.com/f/downloads/download.asp?id=4B182DC4-898A-474A-A61C-E3919D1FB990

Why Install This Hotfix?

This hotfix resolves an issue where the Run Command on Aegis Server activity does not correctly interpret double quotation marks (") in the Arguments parameter, such as DSQuery User -samid "username".

Before you apply this hotfix, if you use double quotation marks in the Argument parameter on the Run Command on Aegis Server activity, the activity fails at run time. After you apply this hotfix, the Run Command on Aegis Server activity correctly interprets double quotation marks in the Argument parameter at run time. (ENG259558)


Installing This Hotfix

Complete the following steps to install this hotfix.

To install this hotfix:

  1. Log on to the Aegis Server computer with a local administrator account.
  2. Run the Aegis20_Hotfix71444.exe file.
  3. Follow the instructions in the wizard until you have finished installing the hotfix.

The hotfix installation program automatically restarts the following Aegis services:

  • NetIQ Aegis Namespace Provider
  • NetIQ Aegis Engine
  • NetIQ Aegis Activity Broker
  • NetIQ Aegis Correlation Engine

Modified Files

This hotfix modifies the following files in the IQConnect folder on the Aegis Server computer, by default C:\Program Files\NetIQ\Aegis\IQConnect:

  • \bin\NetIQGeneric_1_2.dll (Build Number 2.0.1.265)
  • \pgapps\NetIQGeneric_1_2\bin\NetIQGeneric_1_2.dll (Build Number 2.0.1.265)
  • \bin\NetIQGeneric_1_2.pdb
  • \pgapps\NetIQGeneric_1_2\help\en-US\netiqgeneric_runcommand.html

This hotfix adds the following files to the C:\Program Files\NetIQ\Aegis\IQConnect\HotFixes\Aegis20_Hotfix71444 folder on the Aegis Server computer:

  • Aegis20_Hotfix71444.log
  • Aegis20_Readme71444.htm


Contact Information

Please contact us with your questions and comments. We look forward to hearing from you.

For detailed contact information, see the Support Contact Information Web site.

Cause

This is caused by a known issue in the NetIQ Aegis Run Command for Aegis Server activities.

Additional Information

Formerly known as NETIQKB71444