Failed scripts for a response to a Windows 2008 event. (NETIQKB71442)

  • 7771442
  • 16-Jan-2009
  • 06-Mar-2012

Environment

Hotfix 71442 resolves an issue with Security Manager automatically running scripts in response to events on Microsoft Windows Server 2008 agent computers. Before you apply this hotfix, when you configure Security Manager to respond to a specific, unscheduled event by running a script, Security Manager does not run the specified script. After you apply this hotfix, all script responses run correctly as configured. This issue only affects Security Manager agents installed on Windows Server 2008 computers.

This hotfix requires NetIQ Security Manager 6.0 Service Pack 3 on the central computer and agent computers. Agent computers must also have Microsoft Windows Server 2008 installed.

Situation

A hotfix has been created to correct the script failures for response to Windows 2008 events.

Resolution

This hotfix is superceded by Security Manager 6.0 Service Pack 4

 

Complete the following steps to install this hotfix.

To install this hotfix on your central computer and all Windows Server 2008 computers with managed agents installed:

  1. Log on to the central computer using an account that is a member of the local Administrators group.
  2. Run the SM60003_Hotfix71442.exe.
  3. Follow the instructions in the setup program until you have finished installing the hotfix.
  4. Start the Monitor Console in the NetIQ Security Manager program group.
  5. In the left pane, expand Security Manager Monitor Console, and then expand Configuration.
  6. In the left pane, click Central Computers.
  7. On the Action menu, click Scan All Managed Computers.
  8. Click OK.
  9. In the left pane, expand Pending Agents > Installation.
  10. In the right pane, select all agents pending installation.
  11. On the Action menu, click Approve.
  12. Click OK.
  13. In the left pane, click Central Computers.
  14. On the Action menu, click Scan All Managed Computers.
  15. Click OK.
  16. On the Action menu, click Refresh until Security Manager finishes scanning managed computers.
  17. Close the Monitor Console.
  18. Repeat Steps 1 through 17 on each central computer that manages Windows Server 2008 computers with managed agents installed.

To install this hotfix on all Windows Server 2008 computers with unmanaged agents installed:

  1. Log on to the unmanaged agent computer using an account that is a member of the local Administrators group.
  2. Run the SM60003_ManualAgent_Hotfix71442.exe.
  3. Follow the instructions in the setup program until you have finished installing the hotfix.
  4. Repeat Steps 1 through 3 on each Windows Server 2008 computer with an unmanaged agent installed.

This hotfix modifies the EEMResponses.dll file (Build Number 498) in the installation folder, by default C:\Program Files\NetIQ Security Manager\OnePoint.

Cause

Validation code designed to prevent response scripts from running when the data source is a remote computer kicked in and blocked the scripts.

Additional Information

Formerly known as NETIQKB71442