Control Center deployment rules not working, waiting for approval (NETIQKB71408)

  • 7771408
  • 18-Dec-2008
  • 26-Oct-2009

Environment

NetIQ Control Center 7.0.4

Situation

Control Center deployment rules not working, waiting for approval

Resolution

Hotfix 71408 for Control Center version 7.0.4 has been superseded by Hotfix 71647.  Please refer to the AppManager Hotfix Page to get the latest hotfix.

For Control Center version 7.0.1 ONLY, please continue using the following:

For Control Center 7.0.1:

https://www.netiq.com/f/downloads/download.asp?id=CA24E4BE-F344-432D-ACB2-64FA9B110DDE

Why Install This Hotfix?

This hotfix resolves the following Control Center issues:

  • Resolves an issue with Microsoft SQL Server remote deployment after applying Hotfix 70884. Before you apply this hotfix, if you do not select the Skip pre-deployment check option when you create the deployment rule, Control Center does not create a deployment task and remote deployment fails with the following status:
        Waiting for approval.
    If you select the Skip pre-deployment check option, Control Center creates a deployment task for each server in the management group, whether Microsoft SQL Server is installed or not. After you apply this hotfix, Control Center correctly deploys the Microsoft SQL Server module. (ENG243902)
  • Resolves an issue with Microsoft SQL Server remote deployment after upgrading from version 7.0 to version 7.0.1. Before you apply this hotfix, Control Center does not create a deployment task and remote deployment fails. After you apply this hotfix, Control Center correctly deploys the Microsoft SQL Server module. (ENG247475)
  • Resolves an issue with BlackBerry Enterprise Server remote deployment. Before you apply this hotfix, if you do not select the Skip pre-deployment check option when you create the deployment rule, remote deployment fails. After you apply this hotfix, Control Center correctly deploys the BlackBerry Enterprise Server module. (ENG259946)
  • Resolves an issue with creating rule-based management groups from the SQL Database Size template. Before you apply this hotfix, the rule template creates invalid SQL script and SQL job NetIQ Rule Based Dynamic View QDB name fails with the following message:
        Error converting data type varchar to float.
    After you apply this hotfix, if you modify the existing rule or remove it from the management group and create a new rule-based management group from the SQL Database Size template, the SQL job successfully runs. (ENG256805)
  • Resolves an issue with creating rule-based management groups from the SQL Version template. Before you apply this hotfix, if you specify non-numeric data, such as \100, when using the SQL Version template, SQL Server 2005 identifies the data as numeric and SQL job NetIQ Rule Based Dynamic View QDB name fails with the following message:
        Conversion failed when converting the varchar value '\' to data type int.
    After you apply this hotfix, if you modify the existing rule or remove it from the management group and create a new rule-based management group from the SQL Version template, the SQL job successfully runs. (ENG258599)
  • Resolves an issue with creating rule-based management groups from the NT Windows Version template. Before you apply this hotfix, if the repository table contains comma-separated numeric values, SQL job NetIQ Rule Based Dynamic View QDB name fails with the following message:
        Error converting data type varchar to float.
    After you apply this hotfix, if you modify the existing rule or remove it from the management group and create a new rule-based management group from the NT Windows Version template, the SQL job successfully runs. (ENG258589)
  • Resolves an issue with synchronizing multiple AppManager repositories. Before you apply this hotfix, multiple AppManager repositories cannot simultaneously synchronize with the Control Center repository. Instead, the AppManager repositories synchronize one at a time, which can lengthen the synchronization process. After you apply this hotfix, Control Center can synchronize multiple AppManager repositories at once. (ENG258597)
  • Resolves an issue with applying monitoring policies to non-primary AppManager repositories. Before you apply this hotfix, if you try to apply a monitoring policy to a non-primary AppManager repository, Control Center does not update the non-primary AppManager repository with the policy or start the policy jobs. After you apply this hotfix, Control Center correctly applies monitoring policies to non-primary AppManager repositories. (ENG259158)
  • Resolves an issue with access to views on the Chart Console. Before you apply this hotfix, if you use Security Manager to grant a Windows user group access to specific views, the group members have access to all views on the Chart Console. If you use Security Manager to grant individual users access to specific views, the users have access to only the views you specify. After you apply this hotfix, when Windows user group members use the Chart Console, they can access only the views to which you grant access. (ENG258602)
  • Resolves an issue with combining data streams on the Chart Console. Before you apply this hotfix, if you combine two data streams with a different number of data points to create a chart, the Chart Console adds data points to the shorter stream to make it the same length as the longer stream. After you apply this hotfix, the Chart Console displays N/A to indicate gaps between the data points for combined data streams. (ENG262093)
  • Resolves an issue with refreshing the Chart Console. Before you apply this hotfix, if you chart two data streams and one of the streams has data points with 0 values where the other has data points with non-zero values, when you move the streams on the Chart Console, the console does not refresh the 0 values. Instead, it doubles the values of the corresponding data points from the other stream. After you apply this hotfix, the console refreshes the 0 values. (ENG262094)

For more information about the issues resolved with this hotfix, see NetIQ Knowledge Base article NETIQKB71408.

Contents of the Download Package

The download package contains the following files, which are used by the hotfix setup program unless otherwise noted:

  • AM701_Hotfix71408_Setup.exe, the hotfix setup program.
  • BaseInstall.dll.
  • MFC71u.dll.
  • msvcp71.dll.
  • msvcr71.dll.
  • Patch.ini.
  • AM701_ReadMe71408.htm, this readme.
  • Setup Files, a folder that contains AM701_Hotfix71408_CCSetup.exe, the Control Center setup program. The hotfix setup program automatically runs this file to update Control Center.

Installing This Hotfix

Complete the following steps to install this hotfix.

To install this hotfix:

  1. Before running the setup program, close the Control Center Console.
  2. Run AM701_Hotfix71408_Setup.exe on all Control Center computers.

The PATCH.log file lists all changes and problems encountered during the installation process. The Windows installer log file, AM701_Hotfix71408_CCSetup.exe.log, lists only the changes associated with the hotfix installation. By default, these files are located in the \NetIQ\Temp\NetIQ_Debug folder.

Modified Files

This hotfix modifies the following files and stored procedures on all Control Center computers:

  • ADDiagnostic.dll (Build Number 7.0.11207.0)
  • AMChartwiz.dll (Build Number 7.0.11207.0)
  • AutoDeploymentUIExtension.dll (Build Number 7.0.11207.0)
  • AxNQCCJOBPROPERTIESLib.dll (Build Number 7.0.11207.0)
  • DeploymentTechLib.dll (Build Number 7.0.11207.0)
  • NQAMDrv.dll (Build Number 7.0.11207.0)
  • NQCCDBDRV.dll (Build Number 7.0.11207.0)
  • NQCCJOBPROPERTIESLib.dll (Build Number 7.0.11207.0)
  • NQCCMain.dll (Build Number 7.0.11207.0)
  • NQCCServers.dll (Build Number 7.0.11207.0)
  • NQCCServiceMap.dll (Build Number 7.0.11207.0)
  • NQCCShared.dll (Build Number 7.0.11207.0)
  • NQCCUtils.dll (Build Number 7.0.11207.0)
  • NQConsoleExt.dll (Build Number 7.0.11207.0)
  • PluginManager.dll (Build Number 7.0.11207.0)
  • SMVDBHelper.dll (Build Number 7.0.11207.0)
  • AMchartcon.exe (Build Number 7.0.11207.0)
  • RSCPackage.exe (Build Number 7.0.11207.0)
  • TestADUtility.exe (Build Number 7.0.11207.0)
  • AMChart.ocx (Build Number 7.0.11207.0)
  • AMChartHost.ocx (Build Number 7.0.11207.0)
  • NQCCJobProperties.ocx (Build Number 7.0.11207.0)
  • Translator.NT.Version.xml (Build Number 7.0.11207.0)
  • Translator.SQL.DBSize.xml (Build Number 7.0.11207.0)
  • Translator.SQL.SQLVersion.xml (Build Number 7.0.11207.0)
  • Translator.Standard.ObjectTypeWithDetail.xml (Build Number 7.0.11207.0)
  • dplCreatePackage (Build Number 7.0.11207.0)
  • dplCreateTasksForRule (Build Number 7.0.11207.0)
  • dplFetchAppDetectionReportWithAppName (Build Number 7.0.11207.0)
  • dplResetAppDetection (Build Number 7.0.11207.0)
  • dplSetSoftwareReport (Build Number 7.0.11207.0)
  • dplUIFetchInventory (Build Number 7.0.11207.0)
  • GetCorrectAppName (Build Number 7.0.11207.0)
  • MPSyncKSGsAndMembers (Build Number 7.0.11207.0)
  • RESyncDeletedRules (Build Number 7.0.11207.0)
  • SyncQDBObjectType (Build Number 7.0.11207.0)

Cause

Multiple known issues in the Control Center 7.x.

Additional Information

Formerly known as NETIQKB71408

Previous Releases

Hotfix 71247 [Nov 06, 2008]

This hotfix resolved the following Control Center issues:

  • Resolved the Control Center event synchronizing issue. Before you apply this hotfix, the events do not synchronize properly in Control Center as the NetIQ Command Queue Service blocks certain processes. After you apply this hotfix, the Control Center Console will synchronize the events correctly and display them in the events view. (ENG239345)
  • Resolved an issue with job override settings for Knowledge Scripts. Before you apply this hotfix, if you modify any custom property that results in changing the job override value for Knowledge Scripts that are part of a monitoring policy, the jobs associated with these Knowledge Scripts stop and restart at repeated intervals. When you specify the override parameter for the Knowledge Script, the job status gets updated in the monitoring policy when the AppManager and the Control Center repositories synchronize. This results in the job stopping and restarting. After you apply this hotfix, the jobs associated with Knowledge Scripts do not stop and restart even if you modify the custom property that updates the job override values. (ENG248537)
  • Resolved an issue with job override settings not being applied to secondary AppManager repositories. Before you apply this hotfix, if you specify a custom property in the Control Center Console that results in changing the job override value for a Knowledge Script. AppManager does not apply the changes to agents connecting to a secondary AppManager repository. The job override value changes applies only to agents connecting to the primary Appmanager repository. After you apply this hotfix, AppManager applies the changes to agents connecting to both the primary and secondary AppManager repositories. (ENG246454, ENG250319)
  • Resolved an issue with job properties in the Control Center Console. Before you apply this hotfix, if you update the job properties for any monitoring policy job the Control Center Console displays the following error: "Object cannot be cast from DBNull to other types. [FetchJobProperty]". After you apply this hotfix, the Control Center Console no longer displays the error. (ENG246640)
  • Resolved an issue with viewing job properties in the Control Center Console. Before you apply this hotfix, if the Operator Console has any monitoring policy jobs with an error status and you apply Hotfix 71057 to the AppManager repository, the Control Center Console does not display the job properties. The Control Center Console displays the following error: "Object cannot be cast from DBNull to other types. [FetchJobProperty]". However, the Operator Console displays job properties and successfully runs jobs. After you apply this hotfix, the Control Center Console displays the job properties without any error. (ENG250593)
  • Resolved an issue with high CPU usage on the Control Center repository. Before you apply this hotfix, when you stop all jobs and close all events in the Master tab of the Control Center Console, the Control Center repository computer's CPU usage jumps to 100%. After you apply this hotfix, the Control Center repository computer's CPU usage will no longer jump to 100% when you stop all jobs and close all events. (ENG248459)
  • Resolved an event synchronization issue on the Control Center repository. Before you apply this hotfix, events from one or more AppManager repositories do not display correctly on the Control Center Console if you group the events by repositories and view them from the Master management group. After you apply this hotfix, the events from one or more AppManager repositories will synchronize and display correctly in the Control Center Console. (ENG246840)
  • Resolved an issue with display of closed events in Control Center. Before you apply this hotfix, if you select the option to archive events when the event is closed while setting your preferences, and you select the Only open and acknowledged events option in the Cache tab of the management group properties, the Control Center Console displays closed events too. After you apply this hotfix, the Control Center Console does not display closed events if you select the Only open and acknowledged events option in the Cache tab of the management group properties. (ENG248981)
  • Resolved an issue about adding a new SQL user to an existing Control Center user group. Before you apply this hotfix, if you create a new SQL user in the Control Center Console and add the user to an existing Control Center user group that has permissions to access management groups, the user group loses permissions to access management groups. After you apply this hotfix, the Control Center user group retains permissions to access management groups. (ENG246591)
  • Resolved an issue with the synchronization of data in the Control Center repository. Before you apply this hotfix, if the Control Center repository connects to multiple AppManager repositories, the synchronization of data in the Control Center repository takes a long time. The issue occurs because the synchronization tasks running simultaneously on the AppManager repositories block each other. After you apply this hotfix, the synchronization of data in the Control Center repository is faster. (ENG251968)
  • Resolved an issue with data synchronization in the Control Center repository when you remove AppManager repositories. Before you apply this hotfix, if you remove any of the AppManager repositories that are managed by Control Center from a management group, you continue to see the servers in those repositories. The issue occurs because the Control Center repository does not synchronize the server information from the deleted AppManager repositories correctly. After you apply this hotfix, when you remove any of the AppManager repositories that are managed by Control Center, you will no longer see the servers belonging to those repositories. (ENG252968)
  • Resolved an issue with members missing from a management group. Before you apply this hotfix, if Control Center manages multiple AppManager repositories, you cannot see some members of management groups created with any of these repositories. This issue occurs because the Control Center repository does not synchronize the list of views and server groups from the AppManager repositories correctly. After you apply this hotfix, the members of management groups created from the AppManager repositories will not be missing. (ENG247321)
  • Resolved an issue with the display of running jobs in the server view. Before you apply this hotfix, if you sort the server view by the number of running jobs, Control Center does not sort the server view correctly and does not display the correct results on the server view. After you apply this hotfix, the Control Center sorts the server view on the running jobs correctly and displays the correct list of servers. (ENG250666)

Hotfix 71007 [May 07, 2008]

This hotfix resolved the following Control Center repository issues:

  • The Control Center Console did not display updated events because there was no synchronization of events between the Control Center repository and the AppManager repository after you upgraded to AppManager version 7.0.1.
  • The Control Center Console displayed an error when you created a rule-based dynamic view and applied a rule with the not like condition on a management group.
  • If you deleted a user group, a management group, or a permission set from the Control Center Console, you could not create another user group, management group, or permission set with the same name. The Control Center Console displayed an exception if you specified the name of a deleted user group, management group, or a permission set.
  • The Control Center Console did not connect to the AppManager repository when you created a new management group or viewed the properties of an existing management group.
  • The Control Center Console displayed a timeout exception when you created a rule-based management group using the Just Match Object Type expression template and selected a component in the Expressions pane.
  • When you executed the FetchObjectTypeNames rule procedure using Query Analyzer in Microsoft SQL Server, Query Analyzer displayed a timeout exception.
  • If you assigned a rule to a management group, applied a monitoring policy to that group, removed the rule from the management group, and then assigned the same rule to the same management group, the Cache Manager in the Control Center Console displayed an error.
  • When you monitored computers by running a large number of jobs, the management server experienceed a 100% CPU utilization and slowed down.
  • When you created management groups with a monitoring policy, and immediately deleted the management groups, the management groups did not get populated.
  • If the Control Center Console discovered several objects with the same name on the same computer, the Details tab displayed the values of the first discovered object for the rest of the objects.
  • When you grouped objects in the Control Center Console by any value, the expand (+) and collapse (-) buttons did not function for the following views:
    • Deployment Tasks
    • Packages
    • Rules
    • Server
  • When you synchronized events between the Operator Console and the Control Center Console, the synchronization process took several minutes.
  • The temporary database of the SQL Server where you installed the Control Center repository grew at an alarming rate and utilized 100 percent of the CPU memory.
  • The Control Center Console displayed an error when you applied a rule-based dynamic view, and created a rule using the SQL expression template for an AppManager repository.

This hotfix also resolved the following issues related to the rule-based dynamic view:

  • When you used Control Center Console version 7.0.1 with an AppManager repository version 6.0.2, events did not synchronize.
  • If you modified the rule for a rule-based dynamic view, the Control Center Console refreshed the Server view, Job view, and Event view of the associated management group. However, the Event view did not list events for all the available servers.
  • The Command Queue Service displayed an error message when you created a monitoring policy after upgrading the AppManager repository from version 6.0.2 to 7.0.1.
  • The Control Center Console listed all the events of the management group when you selected an embedded Service Map view instead of displaying the events for only the Service Map view.
  • When you discovered a Microsoft Cluster Server (MSCS) on one of the computers in the repository, Control Center did not populate the rule-based management groups.

Note: This hotfix also resolved the following issues caused by Hotfix 70827 :

  • You could not delete servers from the Control Center Console.
  • You could not place servers in maintenance mode.
  • An event failed to trigger proxy-based actions.

If you created management groups based on the Event Severity rule, the management group displayed all computers irrespective of the rule after you installed Hotfix 70827. The workaround for this was to delete the rules that caused the problem and recreate the rules after you installed Hotfix 71007.

The hotfix updated certain stored procedures in the AppManager repository to resolve the previous issues.

Contacting NetIQ Corporation

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