Users are not showing up when adding user to Group under Group Tasks in the Web Console (NETIQKB71319)

  • 7771319
  • 29-Oct-2008
  • 19-Dec-2008

Environment

Directory and Resource Administrator 8.1 SP2

Situation

Users are not showing up when adding user to Group under Group Tasks in the Web Console

Groups are not showing up in Web console when adding user to Group

Resolution

NetIQ Directory and Resource Administrator and Exchange Administrator version 8.1 Service Pack 2 Hotfix 71319

Hotfix 71319 corrects an issue with the way Directory and Resource Administrator (DRA) handles user names and group names containing the following special characters:

  • Hash (#)
  • Semi colon (;)
  • Plus sign (+)
  • Equal sign (=)
  • Greater than (>)
  • Less than (<)
  • Forward slash (/)
  • Double quotes (")
  • Single quote (')
  • Backslash (\)
  • Comma (,)

In the Web Console, DRA displays a blank page in the following scenarios:

  • Under User Tasks after searching for users to add to groups,if you select a user name containing special characters.
  • Under Group Tasks after searching for groups to which you want to add users, computers, or groups, if you select groups with names containing special characters.

This hotfix allows you to correctly add users with names containing special characters to groups and add users, computers, or groups to groups with names containing special characters.                                                             

Run the DRA8102_Hotfix71319.msi file on each computer where you installed DRA Web components.

Hotfix 71319 modifies the following files on each computer where you installed DRA Web components. By default, these files are located in the C:\Inetpub\wwwroot\DRAWeb\WebConsole\BuiltIn\Common\Scripts\SearchForms folder.

  • CreateMultiUserSearchForm.asp
  • CreateMultiComputerSearchForm.asp
  • CreateMultiGroupSearchForm.asp

For more information, see NetIQ Knowledge Base Article NETIQKB71319, available at https://support.netiq.com/dra, or contact Technical Support at www.netiq.com/support.

Cause

The code that parses the filter in Containerenum is failing if the user has a special character in the CN.

Additional Information

Formerly known as NETIQKB71319