Unable to install Service Pack due to MSDTC configuration issue (NETIQKB71279)

  • 7771279
  • 30-Sep-2008
  • 24-Jun-2010

Environment

Security Manager 6.5.2

Security Manager 6.5 SP1
Security Manager 6.5
Security Manager 6.0 SP4
Security Manager 6.0 SP3

Situation

When installing Securiity Manager 6.0 Service Pack 3, Securiity Manager 6.0 Service Pack 4, Security Manager 6.5, Security Manager 6.5 SP1, or Security Manager 6.5.2, you will receive an error regarding MSDTC being improperly configured.

Resolution

Refer to the Notes: section for utilties to confirm the CID is cloned. Once confirmed, use the following steps to resolve this issue:
  1. Use Add Windows Components, and remove Network DTC.
  2. Go to the command line and run: MSDTC -uninstall
  3. Go to the registry and delete the MSDTC keys in HKLM/Software/Microsoft/MSDTC, HKLM/System/CurrentControlSet/Services/MSDTC, and HKEY_CLASSES_ROOT\CID (if they're still there).
  4. Reboot
  5. Go to the command line and run: MSDTC -install 6. Then use Add Windows Components to add Network DTC.
  6. Go to the command line and run: net start msdtc

These steps may need to be performed on all cloned VMs.

 

Cause

The problem is due to the virtual machine (VM) having the same Context ID (CID) as another VM. This occurs when a VM is cloned, as all cloned machines have the same CID.

 

Additional Information

Formerly known as NETIQKB71279

To validate that the Context ID (CID) is the same, you can use a tool from Microsoft called DTCPING. This will need to be run on both machines.

 

To find out more about DTCPING, please visit http://support.microsoft.com/kb/306843 and http://www.microsoft.com/downloads/details.aspx?displaylang=en&FamilyID=5e325025-4dcd-4658-a549-1d549ac17644