Events do not synchronize properly in Control Center Console (NETIQKB71247)

  • 7771247
  • 05-Sep-2008
  • 01-Feb-2011

Environment

NetIQ AppManager 7.0.1 Control Center Console
NetIQ AppManager 7.0.1 Control Center Database

Situation

Events do not synchronize properly in Control Center Console

Monitoring Policy jobs stop and restart at repeated intervals.

If you specify a custom property in the Control Center Console that results in changing the job override value for a Knowledge Script. AppManager does not apply the changes to agents connecting to a secondary AppManager repository.

If you update the job properties for any monitoring policy job the Control Center Console displays the following error: "Object cannot be cast from DBNull to other types. [FetchJobProperty]".

If the Operator Console has any monitoring policy jobs with an error status and you apply Hotfix 71057 to the AppManager repository, the Control Center Console does not display the job properties.

Events from one or more AppManager repositories do not display correctly on the Control Center Console.

If you select the option to archive events when the event is closed while setting your preferences, and you select the Only open and acknowledged events option in the Cache tab of the management group properties, the Control Center Console displays closed events too.

If you create a new SQL user in the Control Center Console and add the user to an existing Control Center user group that has permissions to access management groups, the user group loses permissions to access management groups.

The synchronization of data in the Control Center repository takes a long time when Control Center is connected to multiple AppManager Repositories.

If you remove any of the AppManager repositories that are managed by Control Center from a management group, you continue to see the servers in those repositories.

You cannot see some members of management groups if Control Center is tied to multiple AM Repositories.

If you sort the server view by the number of running jobs, Control Center does not sort the server view correctly and does not display the correct results on the server view.

Resolution

Hotfix 71247 has been release to correct these issues.  You will need to download and install this Hotfix to any AppManager 7.0.1 Control Center Console.

If you have already applied AppManager 7.0.4 to your Control Center Console systems, you DO NOT need to apply this Hotfix.  This hotfix supersedes Hotfixes 71007 and 71095 for the Control Center database and Control Center Console. For more information about the issues resolved in Hotfixes 71007 and 71095, see the Previous Releases section of this article.

You can download Hotfix 71247 from the following location:

https://www.netiq.com/f/downloads/download.asp?id=23BC7073-F8E2-49F6-A853-B7D2BF19C6B8

Why Install this Hotfix?

This hotfix resolves the following issues:

  • Resolves the Control Center event synchronizing issue. Before you apply this hotfix, the events do not synchronize properly in Control Center as the NetIQ Command Queue Service blocks certain processes. After you apply this hotfix, the Control Center Console will synchronize the events correctly and display them in the events view. (ENG239345)
  • Resolves an issue with job override settings for Knowledge Scripts. Before you apply this hotfix, if you modify any custom property that results in changing the job override value for Knowledge Scripts that are part of a monitoring policy, the jobs associated with these Knowledge Scripts stop and restart at repeated intervals. When you specify the override parameter for the Knowledge Script, the job status gets updated in the monitoring policy when the AppManager and the Control Center repositories synchronize. This results in the job stopping and restarting. After you apply this hotfix, the jobs associated with Knowledge Scripts do not stop and restart even if you modify the custom property that updates the job override values. (ENG248537)
  • Resolves an issue with job override settings not being applied to secondary AppManager repositories. Before you apply this hotfix, if you specify a custom property in the Control Center Console that results in changing the job override value for a Knowledge Script. AppManager does not apply the changes to agents connecting to a secondary AppManager repository. The job override value changes applies only to agents connecting to the primary Appmanager repository. After you apply this hotfix, AppManager applies the changes to agents connecting to both the primary and secondary AppManager repositories. (ENG246454, ENG250319)
  • Resolves an issue with job properties in the Control Center Console. Before you apply this hotfix, if you update the job properties for any monitoring policy job the Control Center Console displays the following error: "Object cannot be cast from DBNull to other types. [FetchJobProperty]". After you apply this hotfix, the Control Center Console no longer displays the error. (ENG246640)
  • Resolves an issue with viewing job properties in the Control Center Console. Before you apply this hotfix, if the Operator Console has any monitoring policy jobs with an error status and you apply Hotfix 71057 to the AppManager repository, the Control Center Console does not display the job properties. The Control Center Console displays the following error: "Object cannot be cast from DBNull to other types. [FetchJobProperty]". However, the Operator Console displays job properties and successfully runs jobs. After you apply this hotfix, the Control Center Console displays the job properties without any error. (ENG250593)
  • Resolves an issue with high CPU usage on the Control Center repository. Before you apply this hotfix, when you stop all jobs and close all events in the Master tab of the Control Center Console, the Control Center repository computer's CPU usage jumps to 100%. After you apply this hotfix, the Control Center repository computer's CPU usage will no longer jump to 100% when you stop all jobs and close all events. (ENG248459)
  • Resolves an event synchronization issue on the Control Center repository. Before you apply this hotfix, events from one or more AppManager repositories do not display correctly on the Control Center Console if you group the events by repositories and view them from the Master management group. After you apply this hotfix, the events from one or more AppManager repositories will synchronize and display correctly in the Control Center Console. (ENG246840)
  • Resolves an issue with display of closed events in Control Center. Before you apply this hotfix, if you select the option to archive events when the event is closed while setting your preferences, and you select the Only open and acknowledged events option in the Cache tab of the management group properties, the Control Center Console displays closed events too. After you apply this hotfix, the Control Center Console does not display closed events if you select the Only open and acknowledged events option in the Cache tab of the management group properties. (ENG248981)
  • Resolves an issue about adding a new SQL user to an existing Control Center user group. Before you apply this hotfix, if you create a new SQL user in the Control Center Console and add the user to an existing Control Center user group that has permissions to access management groups, the user group loses permissions to access management groups. After you apply this hotfix, the Control Center user group retains permissions to access management groups. (ENG246591)
  • Resolves an issue with the synchronization of data in the Control Center repository. Before you apply this hotfix, if the Control Center repository connects to multiple AppManager repositories, the synchronization of data in the Control Center repository takes a long time. The issue occurs because the synchronization tasks running simultaneously on the AppManager repositories block each other. After you apply this hotfix, the synchronization of data in the Control Center repository is faster. (ENG251968)
  • Resolves an issue with data synchronization in the Control Center repository when you remove AppManager repositories. Before you apply this hotfix, if you remove any of the AppManager repositories that are managed by Control Center from a management group, you continue to see the servers in those repositories. The issue occurs because the Control Center repository does not synchronize the server information from the deleted AppManager repositories correctly. After you apply this hotfix, when you remove any of the AppManager repositories that are managed by Control Center, you will no longer see the servers belonging to those repositories. (ENG252968)
  • Resolves an issue with members missing from a management group. Before you apply this hotfix, if Control Center manages multiple AppManager repositories, you cannot see some members of management groups created with any of these repositories. This issue occurs because the Control Center repository does not synchronize the list of views and server groups from the AppManager repositories correctly. After you apply this hotfix, the members of management groups created from the AppManager repositories will not be missing. (ENG247321)
  • Resolves an issue with the display of running jobs in the server view. Before you apply this hotfix, if you sort the server view by the number of running jobs, Control Center does not sort the server view correctly and does not display the correct results on the server view. After you apply this hotfix, the Control Center sorts the server view on the running jobs correctly and displays the correct list of servers. (ENG250666)

Contents of the Download Package

The download package contains the following files, which are used by the hotfix setup program unless otherwise noted:

  • AM701_Hotfix71247_Setup.exe, the hotfix setup program.
  • BaseInstall.dll
  • MFC71u.dll
  • msvcp71.dll
  • msvcr71.dll
  • Patch.ini
  • AM701_ReadMe71247.htm , this readme.
  • Setup Files, a folder that contains AM701_Hotfix71247_CCSetup.exe, the Control Center Console setup program.

The hotfix setup program automatically runs this file to update the Control Center Console and the Control Center repository computers.

Installing the Hotfix

To install this hotfix:

  1. Before running the setup program close the Control Center Console.
  2. Run AM701_Hotfix71247_Setup.exe on all Control Center Console and Control Center repository computers.

The PATCH.log file lists all changes and problems encountered during the installation process.  The Windows installer log file, AM701_Hotfix71247_CCSetup.exe.log lists only the changes associated with the hotfix installation.  By default, these files are located in the \NetIQ\Temp\NetIQ_Debug folder.

Changes to Files

This hotfix modifies the following files and stored procedures on the Control Center Console and Control Center repository computers:

  • NQAMDrv.dll (Build number 7.0.11166.0)
  • NQCCMain.dll (Build number 7.0.11166.0)
  • NQCCUtils.dll (Build number 7.0.11166.0)
  • NQCCDBDRV.dll (Build number 7.0.11166.0)
  • NQCCShared.dll (Build number 7.0.11166.0)
  • SyncParameterOverridesToQDB (Build number 7.0.11166.0)
  • SetKSOverrides (Build number 7.0.11166.0)
  • SyncBufferToCache (Build number 7.0.11166.0)
  • FetchSyncCommand (Build number 7.0.11166.0)
  • SyncQDBObjectType (Build number 7.0.11166.0)
  • SyncQDBViewSGInit (Build number 7.0.11166.0)
  • ManagePermissionSet (Build number 7.0.11166.0)
  • ManagementMember (Build number 7.0.11166.0)
  • ManageGroup (Build number 7.0.11166.0)
  • FetchUIMGMembers (Build number 7.0.11166.0)
  • FetchObjectTypeNames (Build number 7.0.11166.0)
  • FetchComponentTypes (Build number 7.0.11166.0)

 

Cause

Multiple issues within the Control Center Console logic.

Additional Information

Formerly known as NETIQKB71247

Previous Releases

Hotfix 71095, [August 27, 2008]

This hotfix resolved the following Control Center Console issues:

  • Resolved value list issue for custom-property values. Before you applied this hotfix, the Control Center Console did not display the value list for pre-existing custom property values. After applying this hotfix, the Control Center Console now displays the value list when you add pre-existing custom property values. (ENG238029)
  • Resolved online status issue for computers without agents installed. Before you applied this hotfix, the Control Center Console displayed an online status for computers that did not have agents installed. After applying this hotfix, the Control Center Console displays the correct online status for computers without agents connected to it. (ENG240368)
  • Resolved job iteration option issue for a UNIX Knowledge Script. Before you applied this hotfix, if you used the Control Center Console and changed the job iterations in the Advanced tab of a UNIX Knowledge Script that was part of a Knowledge Script Group, the Control Center Console did not display the job iteration changes correctly. After applying this hotfix, the Control Center Console now displays the correct job iteration options for a UNIX Knowledge Script when you make changes to the Knowledge Script in the Control Center Console. (ENG244346)
  • Resolved monitoring policy deletion issue in Control Center. Before you applied this hotfix, you could delete a monitoring policy even though the delete permission was not assigned to the permission set for your user group. After applying this hotfix, you can no longer delete monitoring policies in the Control Center Console if you do not have adequate permissions. (ENG246519)
  • Resolved management group view issue for a user with inadequate permissions. Before you applied the hotfix, if your user group was added to a management group and then removed from the group, you could still view the management group in the Enterprise Layout pane even though the permission to view the management group was denied. After applying this hotfix, if you are a part of a user group that has been removed from a management group and you log in to Control Center, you can no longer see the management group in Enterprise Layout pane. (ENG246521)
  • Resolved management group creation issue. Before you applied this hotifx, the Create a new Management Group link was not present on the summary page even though you had the permissions to create a new management group. After applying this hotfix, you can click the Create a new Management Group link on the summary page to create a new management group. (ENG246525)
  • Resolved an issue with events display in Service Map Views.Before you applied this hotfix, if you created event view filters the Service Map view did not display the events correctly when you used the filters. The Service Map view displayed events even if there were no events in the Events view after you applied the filter. After applying this hotfix,the Service Map view displays the events correctly. (ENG248070)


Hotfix 71007, [May 07, 2008]

This hotfix resolved the following Control Center repository issues:

  • The Control Center Console did not display updated events because there is no synchronization of events between the Control Center repository and the AppManager repository after you upgrade to AppManager version 7.0.1.
  • The Control Center Console displayed an error when you create a rule-based dynamic view and apply a rule with the not like condition on a management group.
  • If you deleted a user group, a management group, or a permission set from the Control Center Console, you could not create another user group, management group, or permission set with the same name. The Control Center Console displayed an exception if you specified the name of a deleted user group, management group, or a permission set.
  • The Control Center Console did not connect to the AppManager repository when you created a new management group or viewed the properties of an existing management group.
  • The Control Center Console displayed a timeout exception when you created a rule-based management group using the Just Match Object Type expression template and selected a component in the Expressions pane.
  • When you executed the FetchObjectTypeNames rule procedure using Query Analyzer in Microsoft SQL Server, Query Analyzer displayed a timeout exception.
  • If you assigned a rule to a management group, applied a monitoring policy to that group, removed the rule from the management group, and then assigned the same rule to the same management group, the Cache Manager in the Control Center Console displayed an error.
  • When you monitored computers by running a large number of jobs, the management server experienceed a 100% CPU utilization and slowed down.
  • When you created management groups with a monitoring policy, and immediately deleted the management groups, the management groups did not get populated.
  • If the Control Center Console discovered several objects with the same name on the same computer, the Details tab displays the values of the first discovered object for the rest of the objects. After you apply the hotfix, the Control Center Console displays the correct values for all the discovered objects.
  • When you grouped objects in the Control Center Console by any value, the expand (+) and collapse (-) buttons did not function for the following views:
    • Deployment Tasks
    • Packages
    • Rules
    • Server
  • When you synchronized events between the Operator Console and the Control Center Console, the synchronization process takes several minutes.
  • The temporary database of the SQL Server where you installed the Control Center repository, grew at an alarming rate and utilized 100 percent of the CPU memory.
  • The Control Center Console displayed an error when you applied a rule-based dynamic view, and created a rule using the SQL expression template for an AppManager repository.

This hotfix also resolved the following issues related to the rule-based dynamic view:

  • When you used Control Center Console version 7.0.1 with an AppManager repository version 6.0.2, events did not synchronize.
  • If you modified the rule for a rule-based dynamic view, the Control Center Console refreshed the Server view, Job view, and Event view of the associated management group. However, the Event view did not list events for all the available servers.
  • The Command Queue Service displayed an error message when you created a monitoring policy after upgrading the AppManager repository from version 6.0.2 to 7.0.1.
  • The Control Center Console lists all the events of the management group when you selected an embedded Service Map view instead of displaying the events for only the Service Map view.
  • When you discovered a Microsoft Cluster Server (MSCS) on one of the computers in the repository, Control Center did not populate the rule-based management groups.

Note: This hotfix also resolved the following issues caused by Hotfix 70827 :

  • You could not delete servers from the Control Center Console.
  • You could not place servers in maintenance mode.
  • An event failed to trigger proxy-based actions.
  • If you created management groups based on the Event Severity rule, the management group displayed all computers irrespective of the rule after you installed Hotfix 70827. The workaround for this was to delete the rules that caused the problem and recreate the rules after you installed Hotfix 71007.

Contacting NetIQ Corporation

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