Agent refused connection error when trying to register an Windows Agent. (NETIQKB71242)

  • 7771242
  • 04-Sep-2008
  • 10-Dec-2008

Environment

NetIQ Secure Configuration Manager 5.7

Situation

When attempting to register an agent it comes back with an Agent vssl://Machinename:1622 (IP Address) refused the connection. error message. No matter what is done with the agent there seems to be no method to get the agent to accept the connection. The Core IP has been set and this still does not resolve the issue as well as replacing the IP address in the host name to bypass DNS.

Resolution

Install hotfix 71242 to resolve the issue, then Core Services will choose the correct IP to use that is specified.

https://www.netiq.com/support/vsm/extended/hotfixes.asp

Cause

The target agent is only able to communicate on a certain NIC card, however regardless of what IP is specified core chooses the wrong path. 

Additional Information

Formerly known as NETIQKB71242