Environment
NetIQ AppManager 7.0.1
Situation
How do I reapply Service Pack 1 for AppManager 7.0 if the upgrade did not complete successfully the first time?
Resolution
In order to reinstall Service Pack 1 in the event that the initial upgrade to SP1 was not successful, please perform the following steps:
- Stop All NETIQ MS's attached to the QDB.
- Backup QDB
- Change the registry on the QDB Machine:
- IE - 7.0.0.0 in QDB key: hklm > software > netiq > appmanager > 4.0 > QDB > IE - 7.0.0.0
- Uninstall info in the uninstall key: hklm > software > microsoft > windows > uninstall > {unique guid} > Display Version to 7.0.0.0 V ersion to 0x07000000
Retry the installation and it should allow it to continue after these changes have been made.
Cause
Certain changes were made to the server when the install failed to succeed the first time that were not rolled back when the installation failed.
Additional Information
Formerly known as NETIQKB71232